Survey123 - Date off by a day

222
3
Jump to solution
10-19-2021 04:07 PM
RickeyFight
MVP Regular Contributor

I am using Survey123 Connect. I am pulling in an existing feature service using Enterprise 10.6.1. The survey is using a table from that service. The problem I am facing is that the date is off by a day.

In the app the data shows today as tomorrow. In the image below. The data that is the 18th is today data in the geodatabase. 

RickeyFight_0-1634684632283.png

 

Here is what pro shows. It has data in today date. 

RickeyFight_1-1634684712288.png

 

I need both these days to be the same. I think it is a UTC issue but I cannot figure it out.  I am in PST. 

 

 

 

0 Kudos
1 Solution

Accepted Solutions
KenBuja
MVP Honored Contributor

You have to explicitly set the time zone for the feature service. You're correcting in thinking that it is a UTC issue. The system assumes that it is UTC if you don't set it as PST.

View solution in original post

3 Replies
KenBuja
MVP Honored Contributor

You have to explicitly set the time zone for the feature service. You're correcting in thinking that it is a UTC issue. The system assumes that it is UTC if you don't set it as PST.

View solution in original post

RickeyFight
MVP Regular Contributor

@KenBuja 
How do I do this? I am using a table so I have to add a random layer just to publish the layer.

 

Edit:

I am publishing now with that change. I will let you know if that works. 

 

 

0 Kudos
RickeyFight
MVP Regular Contributor

@KenBuja 

That worked thanks! 

0 Kudos