Survey123 Conditional group of questions not appearing in mobileapp (but work fine in webapp)

127
5
08-15-2022 07:12 AM
KatieFrith
New Contributor II

Hello,

I'm developing a prototype survey 123 app using Survey 123 connect.

In the excel form I have a group of questions that are only set to appear when either Question B or Question C are selected as 'yes'.(nb. Question B is itself within a group of questions that only appear when the answer to Question A is 'yes')

I have set this using the relevant column at the group level with the following statement:

${Question_B}='yes' or ${Question_C}='yes'

This works fine in Survey123 Connect and in the webapp - displaying the conditional group of questions when yes is selected for either B or C.

However, in the mobile app the group of questions only appears when Question_B (The question itself within a conditional group) is selected as 'yes'. When Question_C is selected the group of questions do not appear and I cannot submit the response.

I've set the style of the form to 'pages' mode. 

Can anyone see what I'm doing wrong? Please let me know if any further info is required. 

 

Katie

 

 

 

 

 

 

 

0 Kudos
5 Replies
DougBrowning
MVP Notable Contributor

Post the form these are often caused by using a reserved word or using + vs concat.

Look for any green error warnings in the cells.

0 Kudos
KatieFrith
New Contributor II

Hi Doug,

 

I've attached the form. 

 

For reference, question A is row 4, Question B row 38 and Question C row 5. The conditional group of questions begin on row 44.

 

Thank you

0 Kudos
DougBrowning
MVP Notable Contributor

My guess is it is because the second question is inside a repeat.  Not sure if that was on purpose.  Also what if they answered some repeats yes and some no?  My guess is after the repeat is created they hit + and then a blank repeat is showing.  At that point the value of C is "" and not yes.

Sorry Not sure what you want the logic to be.  Can you move C outside the repeat? 

 

0 Kudos
KatieFrith
New Contributor II

Hi Doug,

The survey I'm trying to create - essentially during a reserve patrol the ranger needs to record 1) Any visitor interactions 2) End of patrol details (whether or not visitors were encountered). I had issues initially because I wanted the visitor interaction questions inside the repeat to be set to required, but if a ranger has no visitor interactions this constraint would prevent them from filling in the second part of the survey (End of patrol details). 

Hence why I set the visitor interaction questions to appear only if 'yes' was selected in response to the question 'Are you recording an interaction with a visitor?' .

However, I definitely overcomplicated things and have now removed the conditional question within the repeat and created a single 'Is this the end of your patrol?' question which will bring up the end of patrol questions if the answer is 'yes' . 

Unfortunately I'm encountering the same issue with the end of patrol questions appearing in survey123 connect but not on the mobile app. It may be that I remove the conditional questions entirely and use 'appearance' to minimise groups of questions by default.

Thank you for your help 🙂 

0 Kudos
KatieFrith
New Contributor II

Made a minor adjustment by keeping the conditional questions in, but setting the appearance of the group as 'compact' rather than 'fieldlist' - seems to have resolved the issue.