Survey123 Analyze tab freezes when subsetting date fields

70
1
2 weeks ago
russell-SVW
New Contributor

Hi all,

 

I have made a Survey123 form from an existing feature layer in Survey123 Connect. I have matched all of the field types to the types they should be interpreted, and I have organized the question structures as they all should be. The survey published without issue. 

Now I have ~2000 records that were published on the same day, I therefor cannot select and filter by submission date, but I do have a field called "Date" in my data.

When I open the Analyze tab, everything works fine without issue, graphs show up, can hide fields as needed, I can even subset by string values if I want. However, if I try to subset by my Date field with the filter "Date is between XX/XX/XXXX and YY/YY/YYYY", the apply button, when pressed, will continually load endlessly without actually applying the filter. 

 

I have tried to do this with every type of filter for the Date field - "is", "is not", "is between", "starts with", etc. They all fail to load.

 

Please help!

0 Kudos
1 Reply
magisian
Occasional Contributor III

'Date' is a reserved word and should not be used as a field name in Survey123 Connect.

Targeting an existing feature service should inherit the field types. You should not need to change these and I can envisage issues if you have i.e. mixed string and date.

Can you share the XLSForm?

Would suggest taking a look at the data itself. What format is the field and what values are in it? Is there invalid data? String values, a mix of dd/mm/yyyy and mm/dd/yyyy?

I don't believe the form is relevant for the analyze tab. Sounds like you have some data issues or it's from the use of the keyword 'date' as the fieldname.

Please don't forget the kudos 🙂