Stuck on "updating survey form package"

112
3
Jump to solution
a month ago
3CDCOrganizationalAccount
New Contributor III

When trying to republish a survey in Survey123 Connect, the survey gets stuck 'updating survey form package'. I read a previous post regarding this issue (see: https://community.esri.com/t5/arcgis-survey123-questions/survey123-connect-stuck-on-quot-updating-su...) and identified that the issue is probably related to me reorganizing my files in ArcOnline. I tried returning the form and feature layers to what I believe is their original location in my base folder, but the issue seems to persist. Any ideas on what to do?

Thanks!

3CDCOrganizationalAccount_0-1632836805957.png

 

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
DougBrowning
MVP Frequent Contributor

The folder id may have still changed.  Go into the iteminfo file on you local machine and change it to the id of the new folder.

View solution in original post

0 Kudos
3 Replies
DougBrowning
MVP Frequent Contributor

If you recreated the folder it will get a new folder id (each folder has an id just like any other item in AGOL).

See this post on how to edit the folder.  Good idea to never move anything in AGOL.

https://community.esri.com/t5/arcgis-survey123-questions/survey-won-t-publish-as-form-was-moved-to-a...

Hope that does it.

0 Kudos
3CDCOrganizationalAccount
New Contributor III

I did not recreate the folder, I moved it back to the home folder where it was originally. I am confused on how to edit the folder. I should just change the name of the iteminfo folder and the survey will recreate a new one with the updated folder location?

0 Kudos
DougBrowning
MVP Frequent Contributor

The folder id may have still changed.  Go into the iteminfo file on you local machine and change it to the id of the new folder.

View solution in original post

0 Kudos