Power automate not triggering for survey based a feature service

122
2
Jump to solution
10-06-2022 08:41 PM
MangatuIntegrated
New Contributor II

I have a timesheet process based on a feature service. The user inputs details in an Input form and submits the survey. The manger then goes into the inbox and opens a Review form, a copy of the details from the Input form, and checks a box authorising the timesheet, and submits it. This all works as I want it to.

I then have a power automate webhook which takes the relevant data from the Review form (if its been authorised) and populates an Excel spreadsheet. 

I tested this Power Automate part by filling data directly into the Review survey, and it worked beautifully.

However, when I tried to test the whole process, by filling the Input form, then authorising the details in the Review form, the trigger failed and the excel spreadsheet was not populated.

Any ideas why this would be?

0 Kudos
1 Solution

Accepted Solutions
CarlisleHaworth1
New Contributor III

This may be related to a setting that gives permission to the webhook trigger to recognize edits of existing data in S123 (the ones in the inbox) as opposed to new submissions in the input form. By default, this is turned off. Here are the steps to get to that setting. First, open your form on the S123 management site:

CarlisleHaworth1_0-1665160569320.png

Then click on the Settings tab and then click Webhooks:

CarlisleHaworth1_1-1665160754668.png

This will show you all the webhooks which are associated with your survey form. Click on the pencil under Operations to edit the settings for the webhook in question: 

CarlisleHaworth1_2-1665160928002.png

This will open up the webhook settings and make sure that "Existing record edited" is checked on:

CarlisleHaworth1_3-1665161133005.png

try that and report back if it helps!

 

View solution in original post

2 Replies
CarlisleHaworth1
New Contributor III

This may be related to a setting that gives permission to the webhook trigger to recognize edits of existing data in S123 (the ones in the inbox) as opposed to new submissions in the input form. By default, this is turned off. Here are the steps to get to that setting. First, open your form on the S123 management site:

CarlisleHaworth1_0-1665160569320.png

Then click on the Settings tab and then click Webhooks:

CarlisleHaworth1_1-1665160754668.png

This will show you all the webhooks which are associated with your survey form. Click on the pencil under Operations to edit the settings for the webhook in question: 

CarlisleHaworth1_2-1665160928002.png

This will open up the webhook settings and make sure that "Existing record edited" is checked on:

CarlisleHaworth1_3-1665161133005.png

try that and report back if it helps!

 

MangatuIntegrated
New Contributor II

That did the trick.

Thanks very much for your help!

0 Kudos