Parent GlobalId

297
3
10-20-2021 06:23 AM
SectoAdmin
New Contributor

Hey,

I have set up a survey using an already created Feature Service and an already created Survey 123 form. I had to amalgamate the two even tho they had different types. I went out to test the survey using field maps after I launch the survey it wouldn't let me finish as It said the parent global Id was required.

SectoAdmin_0-1634735812688.png

I made this a required field as it important.

Should this not auto populate as it is launched from the asset?

I have put in esriFieldTypeGUID in bind::esri:fieldType

SectoAdmin_1-1634736097677.png

I am a bit lost on this, any help?

Go raibh mile maith agat.

 

0 Kudos
3 Replies
DeonLengton
Esri Contributor

Hi

The bind::esri::fieldType merely indicates the data type of the question, it wont automatically populate the parentglobalid with the GlobalID of your Asset.

I dont think your survey is set up correctly - perhaps sharing your survey XLXS file would help us to assist further.

0 Kudos
SectoAdmin
New Contributor

Hey Deon,

Find attached the survey Xls,

This is the result of me adding the survey and the feature layer

0 Kudos
Oretana_
New Contributor II

Hi,

If you want to use an existing service to create a form in Survey It is mandatory to have the globalID in this service.

If you are the owner of the service you can add it in ArcGIS Pro or ArcGIS Desktop and republish it.

I have tried to create a form from a service without globalID and I got the following message:

"The entity service does not meet the requirements of a survey.
The supportsApplyEditsWithGlobalID property must be true."

Oretana__0-1634738933247.png