Once() not working in new body::esri:visible column

96
2
Jump to solution
05-19-2022 12:46 PM
ByronTsang
New Contributor II

In an older (pre- body::esri:visible functionality) survey, I used the once() function in my Relevant expressions to turn fields on as needed, but to retain them if the upstream relevance trigger was changed.  That function seems to no longer work in both the Relevant and body::esri:visible columns.

In both, I'm finding that changing the field that triggers relevance/visibility continually re-evaluates, seeming to ignore the once() function entirely.  Did something change? am I missing something obvious?

0 Kudos
1 Solution

Accepted Solutions
ZacharySutherby
Esri Regular Contributor

Hello @ByronTsang

One alternative workflow you can use is use a calculate question to store the once calculation, then set the relevancy based on the calculate question. 

For example: 

 

typenamelabelcalculationrelevant
select_one yes_noexample2Example select_one question  
noteexample4Example 4once(${example2}) 
textexample3Example 3 ${example4}='yes'
Thank you,
Zach

View solution in original post

0 Kudos
2 Replies
ZacharySutherby
Esri Regular Contributor

Hello @ByronTsang

One alternative workflow you can use is use a calculate question to store the once calculation, then set the relevancy based on the calculate question. 

For example: 

 

typenamelabelcalculationrelevant
select_one yes_noexample2Example select_one question  
noteexample4Example 4once(${example2}) 
textexample3Example 3 ${example4}='yes'
Thank you,
Zach
0 Kudos
ByronTsang
New Contributor II

Thanks, Zach - I'll give this a try.

0 Kudos