Multiple photos and annotations - cutting the photo

189
6
Jump to solution
01-21-2022 01:41 PM
CrisjovanoGumaraes
New Contributor II

I have configured the xlsform (apperance column) to "multiline annotate". And it works fine. I can take the picture and do annotation, but when I confirm the photo is cut. Any idea what is wrong.

... taking photos

CrisjovanoGumaraes_0-1642801106765.png

... after confirmed button

CrisjovanoGumaraes_1-1642801145752.png

 

I have ajusted all zooms and no success. 

 

 

 

0 Kudos
1 Solution

Accepted Solutions
Philip-Wilson
Esri Notable Contributor

Hi @CrisjovanoGumaraes,

If the issue is not occurring in the current release version from app store, it is likely the issue is related to the AppStudio version and Survey123 template version you are using.

When a Qt canvas is used in the app, we have to scale images based on the scale factor and device pixel ratio of the device/screen being used. There are many areas of the code and fixes/patches from Qt that resolve issues around only 1/4 image being displayed, which is a scale factor problem.

If you can confirm the exact version of AppStudio and which template version you have, that will help?

It may be worth waiting until the next 3.14 update of the template is available, as that will include fixes that the previous template may not.

Regards,

Phil.

View solution in original post

0 Kudos
6 Replies
Philip-Wilson
Esri Notable Contributor

Hi @CrisjovanoGumaraes,

Can you please confirm what version of field app you are using, and what make/model device and Android OS version?

Also can you go into the Settings menu, and About screen, press and hold on the AppStudio icon at bottom to expose all details, and then screenshot the AppFramework display scale factor section.

And can you confirm the exact workflow. Are you taking a photo with in built camera, or selecting from a gallery a photo already captured with different camera? Then you save the canvas, go back to the form, and then open the image again, and that is where you only see 1/4 of the image?

Regards,

Phil.

0 Kudos
CrisjovanoGumaraes
New Contributor II

Hi Philip.

I am using the AppSutudio 5.2.133 version. I have created an application from Survey123 template.

CrisjovanoGumaraes_0-1643135135141.png

I am taking a photo in build camera, save and back to the form. Yes, it shows 1/4... of the image. And all photos are cut.

obs: I have tested with Survey 123 with the same forms and worked well.

 

 

0 Kudos
Philip-Wilson
Esri Notable Contributor

Hi @CrisjovanoGumaraes,

If the issue is not occurring in the current release version from app store, it is likely the issue is related to the AppStudio version and Survey123 template version you are using.

When a Qt canvas is used in the app, we have to scale images based on the scale factor and device pixel ratio of the device/screen being used. There are many areas of the code and fixes/patches from Qt that resolve issues around only 1/4 image being displayed, which is a scale factor problem.

If you can confirm the exact version of AppStudio and which template version you have, that will help?

It may be worth waiting until the next 3.14 update of the template is available, as that will include fixes that the previous template may not.

Regards,

Phil.

0 Kudos
DerrickWestoby
Occasional Contributor III

In the "parameters" column, do you have a max pixel size set?  I noticed something similar when I started using this just last week. 

DerrickWestoby_0-1643045239101.png

 



0 Kudos
CrisjovanoGumaraes
New Contributor II

Thanks Derrick. No, but I have added the parameters right now, and no success. 

 

0 Kudos
DerrickWestoby
Occasional Contributor III

Still no effect if you change the value to something like 1280?   

0 Kudos