Inbox freezing up? (staying blue after press)

173
7
Jump to solution
3 weeks ago
BenWan
by
New Contributor III

Hi, I have enabled Inbox for Survey123 where I give out assignments to my users via a Query based on layer data. I have multiple users, maybe around 10, that tell me that when they tap on the Inbox button, it highlights it blue, and then gets stuck, and it might get stuck there for maybe 5 minutes and then it will bring them to the inbox. Any idea as to why this is happening? Like I mentioned, this happened to about 10 people and they are becoming frustrated. Thanks.

0 Kudos
2 Solutions

Accepted Solutions
Philip-Wilson
Esri Frequent Contributor

Hi @BenWan,

Just letting you know that the Early Adopter Community (EAC) has just been updated with new 3.13 October Update RC builds. These builds include a fix for large surveys with slow loading times, when trying to open the drafts or inbox folder, and when submitting surveys. If you have time, please take a look and test out your surveys with these new builds, and let us know any feedback in the EAC forums. We hope to get this update released and available in the app stores as soon as possible.

Regards,

Phil.

View solution in original post

0 Kudos
Philip-Wilson
Esri Frequent Contributor

Hi @BenWan,

Can you confirm you installed version 3.13.234 from Apple TestFlight, it only just got approved by Apple, so if you did it earlier today you may have got previous version 3.13.229 which has the issue reported above.

If you are still seeing the issue with version 3.13.234, can you please send me your XLSForm (xlsx file and media folder) so I can take a look. Without your survey form we can not troubleshoot it further, as with the latest build available on EAC we are seeing all the other customer forms working as expected now.

Regards,

Phil.

View solution in original post

0 Kudos
7 Replies
Philip-Wilson
Esri Frequent Contributor

Hi @BenWan,

Are you using the latest 3.13 release? Was this occuring previously with 3.12?

Can you share your XLSForm (xlsx file and media folder) so we can take a closer look?

Regards,

Phil.

0 Kudos
Philip-Wilson
Esri Frequent Contributor

Hi @BenWan,

Just letting you know that the Early Adopter Community (EAC) has just been updated with new 3.13 October Update RC builds. These builds include a fix for large surveys with slow loading times, when trying to open the drafts or inbox folder, and when submitting surveys. If you have time, please take a look and test out your surveys with these new builds, and let us know any feedback in the EAC forums. We hope to get this update released and available in the app stores as soon as possible.

Regards,

Phil.

View solution in original post

0 Kudos
BenWan
by
New Contributor III

Awesome, thanks a lot, I will look into this now. The strange thing is that only some users are experiencing this and I cannot pin down what the cause is. My initial thought was that they were using an old phone, the iPhone7, but I tested this with my own iPhone 7 and did not have this issue. But either way, an update would work out for all of us.

0 Kudos
BenWan
by
New Contributor III

Interesting...I downloaded the new release and now I am experiencing the same thing that my users are experiencing. When I hit the Inbox button, it turns blue and freezes there for a good 20-30 seconds and then my inbox appears. This did not use to happen to me, so I am assuming that I may have been on the old version and my app was not updated yet...

I tried the new build via Testflight and this is still happening. Can developers look into this please? It has been causing a lot of headache with my field staff. Thanks

0 Kudos
Philip-Wilson
Esri Frequent Contributor

Hi @BenWan,

Can you confirm you installed version 3.13.234 from Apple TestFlight, it only just got approved by Apple, so if you did it earlier today you may have got previous version 3.13.229 which has the issue reported above.

If you are still seeing the issue with version 3.13.234, can you please send me your XLSForm (xlsx file and media folder) so I can take a look. Without your survey form we can not troubleshoot it further, as with the latest build available on EAC we are seeing all the other customer forms working as expected now.

Regards,

Phil.

View solution in original post

0 Kudos
BenWan
by
New Contributor III

Hi Phil,

That was it! I went back onto the EAC site and back on Testflight to download 3.13.234 and tried my survey again and it loaded perfectly fine when clicking on Inbox.

When I click on one of my assignments, it does still take a little bit to load, but that problem was there before. Something like 5-10 seconds. However everything did work as intended. I think this issue is that we use repeat groups for photos because we had no other choice. This caused our survey to have 100+ repeat groups and thus creating related tables and a large survey and slow load times. I was wondering if you knew of any resolution to this issue? We weren't able to have multiple photos using the "inbox" method unless it was using repeats, and our consultant at the time acknowledged that it was an engineering thing and might be fixed later on down the road. Would you know of any progress on this?

Thanks again!

Philip-Wilson
Esri Frequent Contributor

Hi @BenWan,

Instead of using repeat groups which create related tables and store the attachments in the seperate tables related to the main feature, have you considered using the multiline appearance on image questions. This was added to image questions a while ago, and recently we now support attachments in the Inbox.

With the 3.13 release, the Inbox and workflows involving editing existing features now support viewing and adding image attachments to existing features. This means you can now view and add new images to surveys via the Inbox, both inside and outside of repeats.

Please refer to below links for more information:

https://doc.arcgis.com/en/survey123/desktop/create-surveys/xlsformsappearance.htm#ESRI_SECTION1_792A...

https://doc.arcgis.com/en/survey123/desktop/create-surveys/xlsformmedia.htm

https://community.esri.com/t5/arcgis-survey123-blog/survey123-tricks-of-the-trade-photos/ba-p/897907

https://community.esri.com/t5/arcgis-survey123-blog/whats-new-in-arcgis-survey123-september-2021/ba-...

Regards,

Phil.

0 Kudos