Inbox date issue

180
3
a month ago
AllisonWebb
New Contributor II

We've found that the Inbox displays the Modified Date instead of the Observation Date.  The Observation Date is more useful to us.  I don't see a way to change that date for sorting.  I've been trying to add the Observation Date to the instance_name to see if that is a good workaround.

I cannot get the date to appear in the Inbox.  I see it in the Outbox if I send it there, but it does not appear in the Inbox.  I see a space where it should be at the beginning of the name.  

Would be best if we could replace the Modified Date with the Observation Date.  If that is not possible, what am I doing wrong with the instance_name for the Inbox?

Appreciate any help.  Thank you!

AllisonWebb_0-1713548662793.png

 

 

 

0 Kudos
3 Replies
KerryKang
Occasional Contributor III

Can you store the observation date in the text format and added it as an instance name? I usually create a field called time stamp and move date into yy-mm-dd-hh-mm-ss format. 

0 Kudos
RobertAnderson3
MVP Regular Contributor

Does your date_observed have calculationMode=always set by chance? I see you are setting it to now() so I am wondering if it's calculating in the background to match the modified_date without realizing?

I'm wondering if it's something to do with the calculate field type as well? Does it actually store data in the feature layer or no? If it doesn't maybe that's why the Inbox doesn't show the value, but the Outbox does?

The other thing like Kerry suggested would be formatting the date, in my instance_name I have the date added as format-date(${ServiceDate},'%b %d, %Y')

0 Kudos
AllisonWebb
New Contributor II

That worked - Thank you!  Adding the format-date to the instance_name instead of creating a new calculate field was the key.

 

0 Kudos