Error: An error occurred when checking the report template. No tag "w:tr" was found at the left

299
4
12-08-2023 04:10 AM
DuncanG
New Contributor II

I am tweaking an existing custom report template and keep receiving a No tag "w:tr" was found at the left error message. There are a couple of similar posts on here with the error on the right, but the solutions havent worked for me. 

The custom report that this is based on works fine, so I am stuck on how to fix this. Any help would be much appreciated! 

0 Kudos
4 Replies
abureaux
MVP Regular Contributor

This means that one of your curly braces is wrong. E.g., replaced { with (.

Can also happen if you have a logic statement like IF that is missing something. E.g.,: ${pca_elev_el_date_yn==”no”} should be ${if pca_elev_el_date_yn==”no”}

abureaux
MVP Regular Contributor

You have a good number of pages there, so a quick scroll through isn't really possible. I'd suggest deleting out parts of the document, try uploading, and narrow down where in the doc the issue starts. I did find a couple things below though.

This:
${ if Inspection_Type != “On Road Cycling Trail Registration Inspection” && Inspection_Type != “On Road Cycling Trail Inspection}

Should be:
${ if Inspection_Type != “On Road Cycling Trail Registration Inspection” && Inspection_Type != “On Road Cycling Trail Inspection"}

And, I don't think this is an issue, but seems odd to be this:
${if Total_Issue_Percentage >= 70} ${if Total_Issue_Percentage < 70 || Info_Total_Percentage < 70 || Fencing_Total_Percentage < 70 || Litter_Total_Percentage < 70 || Road_Total_Percentage < 70 || Route_Total_Percentage < 70 || Signage_Total_Percentage < 70 || Surface_Total_Percentage < 70 || Structures_Total_Percentage < 70 || Vegetation_Total_Percentage < 70 || Waymarking_Total_Percentage < 70 }*${/}${/}

Instead of:
${if Total_Issue_Percentage >= 70 || Total_Issue_Percentage < 70 || Info_Total_Percentage < 70 || Fencing_Total_Percentage < 70 || Litter_Total_Percentage < 70 || Road_Total_Percentage < 70 || Route_Total_Percentage < 70 || Signage_Total_Percentage < 70 || Surface_Total_Percentage < 70 || Structures_Total_Percentage < 70 || Vegetation_Total_Percentage < 70 || Waymarking_Total_Percentage < 70 }*${/}

DuncanG
New Contributor II

Thanks for looking over this, I know it's a bit of a beast!

After a lot of searching, I found one of my statements started inside a table but had the ${/} outside the table. Moving the ${/} inside seemed to do the trick. 

0 Kudos
abureaux
MVP Regular Contributor

That would do it! Glad you found the issue. These errors can be a little ambiguous at times!