Select to view content in your preferred language

Difficulty with search()

209
3
Jump to solution
4 weeks ago
Rar_Katia
New Contributor II

Hello, I'm using Survey123 Connect. I've been asked to add a new CSV search() question type to my survey. I've used an existing question of the same type to format the question, so I have a lot of confidence that this should work (since it already does elsewhere in the survey). In the Connect window, everything works correctly. In the online view, the list for my new autocomplete question does not populate, whereas the older question still does.

 

I've tried removing blanks from the column names in the CSV. I've updated the name of the CSV. I've checked that Connect is updated and that the survey manager is allowing use of the most recent version. I've restarted my computer. And exhausted Community questions.

 

What could I be missing? Any obvious reasons that a second CSV search() appearance wouldn't work?

0 Kudos
1 Solution

Accepted Solutions
DougBrowning
MVP Esteemed Contributor

You said updated the name.  I think you still cannot have any spaces in the name and the case has to match exactly.  Also open the file in notepad vs excel.  Look for special chars or trailing commas.

If still no post the search code

View solution in original post

0 Kudos
3 Replies
DougBrowning
MVP Esteemed Contributor

You said updated the name.  I think you still cannot have any spaces in the name and the case has to match exactly.  Also open the file in notepad vs excel.  Look for special chars or trailing commas.

If still no post the search code

0 Kudos
Rar_Katia
New Contributor II

Opening in notepad turned out to be the key, thank you! I was able to see that the column names had "" around them due to the text wrapping, fixed it by removing returns after the column name.

0 Kudos
ChristopherCounsell
MVP Regular Contributor

It works in Connect can rule out a lot of formatting issues.

Did you re-publish the survey?

 the online view, the list for my new autocomplete question does not populate, 

... online view? where are you looking? Survey or data? A csv question doesn't create a list in the attribute table

need more info - XLSForm, screenshots, csv files

0 Kudos