Auto-calculate field will not update when using "copy data to new survey"

09-24-2023 10:24 AM
New Contributor II

I have a survey setup for field inspections that includes a read-only auto-calculated field.  The calculation is simply "Field2-Field1=Field3".  The workflow requires the previously submitted survey to be opened from the inbox, and using "copy data to new survey", the editable fields (Field 1 and Field 2) are overwritten by field workers.  The expectation is that Field 3 should auto-update with the new values, and field workers will then submit the new survey. 

This process worked for the first few rounds of data collection, and then Field 3 has "locked up", and will no longer auto-update.   Field 1 and 2 remain editable, but the calculated field retains the original value and does not update or re-calculate to reflect the new values in the editable fields.  The only clue I have found is that when the calculation was working, the text in field 3 was blue, but after it "locked up" it now shows as black (default survey 123 text colors).

There are 2 other calculated fields in the survey form with similar calculations, but all reference unique input fields, and all other calculations will update normally as expected - the issue is isolated only to the first calculated expression in this survey.

Has anyone run into similar issues with calculated fields in Survey 123?  Can't find much out there so any suggestions are appreciated.

0 Kudos
1 Reply
Occasional Contributor III

Have you tried setting calculationMode=always for the calculate field yet?