Relocation Error When running Qt Application Linking libEsriCommonQt.so

67
1
10-19-2021 01:52 PM
GarethBlock_Ti
New Contributor

I'm having issues running my Built CMAKE Qt application with the ArcGIS Esri library linked. I get the error:


/home/user/gazebo_dev/rare/cmake-build-debug/RARE_TEST: relocation error: /home/user/gazebo_dev/arcgis/runtime_sdk/qt100.12/sdk/linux/x64/lib/libEsriCommonQt.so: symbol _ZN9QSslError16staticMetaObjectE version Qt_5 not defined in file libQt5Network.so.5 with link time reference

Gcc Version: 7.5.0
System: Ubuntu 18.04
ArcGIS version: 100.12
QT Version: 5.15.2 (Installed through https://launchpad.net/~beineri/+archive/ubuntu/opt-qt-5.15.2-bionic)

Does anybody have an idea on how to get around this issue?

0 Kudos
1 Reply
JamesBallard1
Esri Contributor

Hi @GarethBlock_Ti ,

We've seen this with other folks reporting similar issues. It seems to happen when you use Qt provided by the package manager or other similar means. These are built with version tagging enabled. We build our SDK against the version of Qt provided by the Qt Company directly. The first thing to try would be downloading Qt from the Qt Company directly and see if that fixes it: https://www.qt.io/download .

If that's not possible, the next thing would be to see if you can obtain the Qt sources and build the version you want using the Qt Company's method. The key would be to disable the version tagging via QT_NO_VERSION_TAGGING during the configure step.

The other one we've seen is "operator delete(void*, unsigned long)@Qt_5".

Let us know if this helps.

0 Kudos