arcgis qt6 support

90
4
a week ago
ics3120
New Contributor

Hi,

I am trying to setup arcgis sdk (v100.14) with my existing Qt framework. Below are the details:

Qt Creator 6.2.0
But when I try to run an example from the ARCGIS project I get an error saying:

:-1: error: Project ERROR: This version of the ArcGIS Runtime SDK for Qt is incompatible with Qt 6

How can i get the precise Qt 5.15.2 version. Please point out the correct qt installation file or any tutorial that has this covered.

Thanks

0 Kudos
4 Replies
GuillaumeBelz
Esri Contributor

Hello,

You can check this page for the System requirements for 100.14: https://developers.arcgis.com/qt/reference/system-requirements/ 

As indicated, Qt6 is not supported by 100.14. You need to install Qt 5.15.2 or later. To do that, you can run the Qt MaintenanceTool and select the correct version of Qt. For the details: https://doc.qt.io/qt-5/gettingstarted.html (at 4:36 in the video).

Do not hesitate if you have more questions.

Guillaume

0 Kudos
ics3120
New Contributor

thank you sir

sir does arcgis support offline maps for ubuntu 20.04 and qt5.15.2 later version

and also we wwant know what version of qt does arcgis support

0 Kudos
ics3120
New Contributor

and also please let us know if there is any version of arcgis version which supports qt6

0 Kudos
GuillaumeBelz
Esri Contributor

Hi,

For the Qt6 support, there is this blog article which explains all the details: https://www.esri.com/arcgis-blog/products/api-cqt/developers/qt-6-support-is-on-the-horizon/

For offline maps, all details are in https://developers.arcgis.com/qt/offline-maps-scenes-and-data/ 

ArcGIS Runtime API for Qt 100.14 supports Qt 5.15.2 or later.

0 Kudos