Supported platforms in MAUI

207
3
Jump to solution
10-06-2022 04:49 AM
esp1rl
by
New Contributor II

Hi, just curious about the supported platforms in ArcGIS Runtime for MAUI. When I see the NuGet platform dependencies I see a minimum of Android 12 (API 31), iOS 14, Mac Catalyst 14.2 and Windows 10 2004 (19041). Does it reflect what the release version of v200 will support?  

MAUI itself is limited to Android 5 (API 21), iOS 10, Mac Catalyst 10.15 and Windows 10 1809 (17763).

NuGet Gallery | Esri.ArcGISRuntime.Maui 200.0.0-beta

Supported platforms for .NET MAUI apps - .NET MAUI | Microsoft Learn

0 Kudos
1 Solution

Accepted Solutions
dotMorten_esri
Esri Notable Contributor

Not quite. One thing to note though: framework target version and minimum supported version isn't the same thing. You can generally target the latest SDK for each platform, and still support older versions, and that's pretty much the case across all our target frameworks.

The catalyst bit is a bit confusing - the OS version is different from the catalyst sdk version. I found a good list here: https://stackoverflow.com/a/69748714/1702326 Our minimum support there is 14.0


Wrt Windows minimum is 19041 in the beta, but we're currently considering changing our minimum supported from minimum support Windows version excluding LTSC versions (which is 19041) , to in the future include the LTSC versions still in mainstream support, which would bring the support all the way down to 17763 until 2024 (Note: v100.15 is 18362 so this increases the lower bound). You will still need to target 19041, but will then be able to set the minimum to 17763.

For Android, the minimum isn't 31 - that's the target. The minimum is 26 for v200 (it was 23 for v100.15). 

View solution in original post

3 Replies
dotMorten_esri
Esri Notable Contributor

Not quite. One thing to note though: framework target version and minimum supported version isn't the same thing. You can generally target the latest SDK for each platform, and still support older versions, and that's pretty much the case across all our target frameworks.

The catalyst bit is a bit confusing - the OS version is different from the catalyst sdk version. I found a good list here: https://stackoverflow.com/a/69748714/1702326 Our minimum support there is 14.0


Wrt Windows minimum is 19041 in the beta, but we're currently considering changing our minimum supported from minimum support Windows version excluding LTSC versions (which is 19041) , to in the future include the LTSC versions still in mainstream support, which would bring the support all the way down to 17763 until 2024 (Note: v100.15 is 18362 so this increases the lower bound). You will still need to target 19041, but will then be able to set the minimum to 17763.

For Android, the minimum isn't 31 - that's the target. The minimum is 26 for v200 (it was 23 for v100.15). 

dotMorten_esri
Esri Notable Contributor

Just to follow up: are there specific minimums you're required to support that isn't covered by the above? Also feel free to provide more feedback in the beta forums: https://esriurl.com/agsrt200beta

esp1rl
by
New Contributor II

Android 12 / API  31 would have been quite restrictive. But as it is v8 there is no problem. Thanks for the clarification, Morten.

We use ArcGIS Runtime with MAUI in our development, and I'll be sure to provide feedback in the beta forums.

0 Kudos