{"Illegal state: The underlying GeoPackage is closed"}

1228
4
07-02-2020 03:04 AM
ShaneHulligan
New Contributor

Has anyone come across an issue when loading a GeoPackage by cloning the FeatureLayers within?

I have a scenario that requires the enclosed FeatureLayers within a GeoPackage to be closed so they can be farmed out to a MapView & SceneView. 

However, when either the MapView or SceneView triggers the Load on a cloned FeatureLayer from a GeoPackage, the following LoadError is presented: {"Illegal state: The underlying GeoPackage is closed"}

I have attached a sample project that demonstrates this behaviour.

Is my scenario achievable?

If so, can anyone explain why when cloning the FeatureLayer does it think the GeoPackage is closed?

Cheers

0 Kudos
4 Replies
MichaelBranscomb
Esri Frequent Contributor

Hi

Thanks for the focused repro; it makes a big difference.

We've reproduced the error you're seeing and have opened an issue in our backlog to aim to address this in a future release. Unfortunately we have not yet been able to identify a workaround. 

Thanks

Mike

0 Kudos
ShaneHulligan
New Contributor

HI Michael,

Thank you for the reply. Do we have a time frame for when this issue may be fixed?

Cheers,

Shane

0 Kudos
MichaelBranscomb
Esri Frequent Contributor

Hi,

This issue has been resolved in current development builds and pending regression testing and release testing we plan to include in the upcoming 100.9 release (expected Q3 2020).

Thanks

Mike

MichaelBranscomb
Esri Frequent Contributor

Hi,

Confirming this issue was addressed in v100.9 (released August 27).

Thanks

Mike

0 Kudos