Graphic rendering when changing spatial references

1491
2
02-07-2017 05:13 AM
KevinSayer
New Contributor III

When changing basemaps on the map view to a basemap with a different spatial reference, polygon graphics in a graphics overlay are successfully reprojected but not always drawn corretly. i.e Sometimes the border is missing and when this occurs the grapic no longer seems to update when its selection status is changed. The IsSelected property can be set but the expected highlight doesn't display

Having spent some time investigating this, it seems to be related to the changing spatial reference in combination with Dynamic rendering mode.  If rendering mode is set to static then the problem seems to resolve itself.

I have published a map on ArcGIS online that uses the BNG spatial reference (27700) and created a small applicaiton to demonstrate the problem. (see attached)

The application starts with a web mercator map and pressing the button toggles to the BNG map. There is a single polygon that automatically reprojects and draws just fine when in static rendering mode, but often fails to draw correctly when the rendering mode is set to dynamic.  The rendering mode can easily be changed via the radio buttons.

Are we doing something wrong or is this a bug?

Tags (1)
2 Replies
MichaelBranscomb
Esri Frequent Contributor

Hi,

Many thanks for the excellent repro app. I have entered an issue in our bug tracking system for further investigation.

Cheers

Mike

0 Kudos
MichaelBranscomb
Esri Frequent Contributor

Hi,

The issue of maintaining the graphic border and selection highlight when switching maps with different spatial references (including non-WebMercator) should be fixed in the next release (summer 2017). Once it is released and you have updated your NuGet packages, please re-test.

Once again, thanks for the excellent, simple repro app.

Cheers

Mike

0 Kudos