Can't add ArcGIS to my build as of 2021 December

178
1
12-16-2021 11:09 PM
AchileasGalatis
New Contributor

Hello.

I followed the guild on the site to add ArcGIS map to my android application but it doesn't work. the error message is "Failed to resolve: com.esri.arcgis.android:arcgis-android:100.13.0". Can someone help me PLEASE!!!!!

The only place it works is their own example project which is outdated. and jcentter() is deprecated.

0 Kudos
1 Reply
GuntherHeppner
Esri Contributor

It looks like you are referencing the arcgis dependency incorrectly. Please refer to our guide docs:
https://developers.arcgis.com/android/get-started/#get-the-api-with-gradle

If you use Gradle, your dependency should be declared like this:

dependencies {
   implementation 'com.esri.arcgisruntime:arcgis-android:100.13.0'
}

0 Kudos