Unable to compile 3.2 and earlier projects after upgading to 3.3 SDK

350
3
Jump to solution
05-08-2024 09:43 AM
StuartBricker2
New Contributor II

I upgraded both ArcGIS Pro and the Visual Studio SDK extensions to version 3.3 this morning.

Subsequently, I receive compilation errors when attempting to build existing projects as per the attached screen capture. As a workaround, I was able to create a new 3.3 project and copy/paste the code into the new project for the script I needed to run at the time. That compiled and ran just fine. 

However we have some larger apps where that workaround is not really viable and I'd like to resolve the issue that is preventing these existing projects from compiling. Clearly something went sideways with the upgrade and I am getting version mismatch errors.

Thanks in advance for any assistance you are able to provide.

0 Kudos
1 Solution

Accepted Solutions
Aashis
by Esri Contributor
Esri Contributor

ArcGIS Pro moved to .NET 8 at release 3.3. so update the target framework to .NET 8 and VS 2022 (17.8 or higher).

More details - https://github.com/Esri/arcgis-pro-sdk/wiki/ProGuide-NET-8-Upgrade

Aashis_0-1715187439392.png

 

View solution in original post

0 Kudos
3 Replies
Aashis
by Esri Contributor
Esri Contributor

ArcGIS Pro moved to .NET 8 at release 3.3. so update the target framework to .NET 8 and VS 2022 (17.8 or higher).

More details - https://github.com/Esri/arcgis-pro-sdk/wiki/ProGuide-NET-8-Upgrade

Aashis_0-1715187439392.png

 

0 Kudos
RichardDaniels
Regular Contributor

Place to start is to ensure your Visual Studio 2022 is at version 17.8 or higher and that you have .Net 8 installed. 

RichardDaniels_0-1715189452278.png

 

StuartBricker2
New Contributor II

Thanks for the replies. I knew it had to be something silly that I was missing. Again. 

0 Kudos