Select to view content in your preferred language

Pro 3.3 SDK Backwards Compatibility

256
1
Jump to solution
a month ago
VidmasKondratas
Esri Contributor

Are ArcGIS Pro 3.3 SDK .NET Add-Ins backwards compatible with ArcGIS Pro 3.2?

0 Kudos
1 Solution

Accepted Solutions
KrisCulin
Occasional Contributor

No. AGP 3.3 uses net8.  If you update your add-in to target the 3.3 NuGet package, then you'll have to update to net8 as well.  At that point, the add-in is no longer compatible with pre-3.3.

However, if you keep your add-in targeting 3.2 or earlier and your target framework stays at net6, then it will be compatible with 3.0-3.3.  net8 can load net6 assemblies but not vice-versa.

We have two configurations that we are keeping on AGP 3.1 NuGet and we've tested them both in AGP 3.3.  Except for a few minor issues we had to fix on our end (regressions when running under the nett8 runtime), everything worked.

Also note that the AGP 3.3 installation changed the location of the RegisterAdin.exe so the earlier NuGet packages won't find it.  You'll need to copy the files from %ProgramData%\EsriCommon (something like that) into the installation folder.  Just search for "RegisterAddin.exe" to find the exact location of the files to copy.  Once copied into the installation folder, the earlier NuGet package versions will find it.  This is from personal experience.

Kris

View solution in original post

1 Reply
KrisCulin
Occasional Contributor

No. AGP 3.3 uses net8.  If you update your add-in to target the 3.3 NuGet package, then you'll have to update to net8 as well.  At that point, the add-in is no longer compatible with pre-3.3.

However, if you keep your add-in targeting 3.2 or earlier and your target framework stays at net6, then it will be compatible with 3.0-3.3.  net8 can load net6 assemblies but not vice-versa.

We have two configurations that we are keeping on AGP 3.1 NuGet and we've tested them both in AGP 3.3.  Except for a few minor issues we had to fix on our end (regressions when running under the nett8 runtime), everything worked.

Also note that the AGP 3.3 installation changed the location of the RegisterAdin.exe so the earlier NuGet packages won't find it.  You'll need to copy the files from %ProgramData%\EsriCommon (something like that) into the installation folder.  Just search for "RegisterAddin.exe" to find the exact location of the files to copy.  Once copied into the installation folder, the earlier NuGet package versions will find it.  This is from personal experience.

Kris