Zonal Statisitcs as table tool output has far fewer objects than defined zones

449
8
Jump to solution
4 weeks ago
Labels (1)
HopeHauptman
New Contributor II

I have over 13,000 zones and the zonal statistics as table tool calculates the majority but only 8000 or so objects then appear in the table. Why is it skipping so many zones? Is 13,000 too many? 

0 Kudos
2 Solutions

Accepted Solutions
DanPatterson
MVP Esteemed Contributor

How the zonal statistics tools work—ArcGIS Pro | Documentation

check the description to identify where things can go wrong, for instance, the section beginning with

To avoid zones disappearing from your output, ensure that each zone contains one or more cell centers from the value raster.


... sort of retired...

View solution in original post

JimTenbrink
Esri Contributor

Hello

Resample works, and using it will let you see explicitly which cells are contributing to which zone, but you could also directly specify the desired cell size when executing the 'zonal stats as table' tool. This avoids the need to create or manage intermediate raster datasets. For example, if you use the ZSAT tool from the Pro UI, you can switch to the tool's environments tab and specify the cell size in the Raster Analysis parameter group.

JimTenbrink_0-1632276400268.png

 

as a general rule, all spatial analyst tools allow you to specify the analysis cell size.

Regards,

-Jim TenBrink

spatial analyst team

View solution in original post

8 Replies
DanPatterson
MVP Esteemed Contributor

Are they all singlepart features?  Are you basing the zones on the OBJECTID field? or some other field (which may have duplicates)

 


... sort of retired...
0 Kudos
Hope_Hauptman
New Contributor III

Yes I am basing it on the ObjectID field. They are polygon features. 

0 Kudos
DanPatterson
MVP Esteemed Contributor

How the zonal statistics tools work—ArcGIS Pro | Documentation

check the description to identify where things can go wrong, for instance, the section beginning with

To avoid zones disappearing from your output, ensure that each zone contains one or more cell centers from the value raster.


... sort of retired...

View solution in original post

Hope_Hauptman
New Contributor III

Yes - the cell size/cell center was the problem. Good suggestion to check description for common problems. Much appreciated. 

0 Kudos
DanPatterson
MVP Esteemed Contributor

glad it worked out


... sort of retired...
0 Kudos
HopeHauptman
New Contributor II

Fr other with this problem: I used the Resample tool to make the cell size smaller on the raster and then no more missing data. 

0 Kudos
JimTenbrink
Esri Contributor

Hello

Resample works, and using it will let you see explicitly which cells are contributing to which zone, but you could also directly specify the desired cell size when executing the 'zonal stats as table' tool. This avoids the need to create or manage intermediate raster datasets. For example, if you use the ZSAT tool from the Pro UI, you can switch to the tool's environments tab and specify the cell size in the Raster Analysis parameter group.

JimTenbrink_0-1632276400268.png

 

as a general rule, all spatial analyst tools allow you to specify the analysis cell size.

Regards,

-Jim TenBrink

spatial analyst team

View solution in original post

Hope_Hauptman
New Contributor III

Great - good to know for future. Thank you!

0 Kudos