Select to view content in your preferred language

What is your recommended way to update Deep Learning Packages when updating to new Pro version (3.3).

248
2
Jump to solution
3 weeks ago
ConstantinePapadakis
New Contributor II

Hello, am looking for your recommendation, watchouts, tips, etc. to upgrade my existing Deep Learning Libraries when I upgrade to Pro version 3.3.  I understand my existing python packages (for 3.2.2) may not or will not be compatible with the 3.3.  So....what is your slickest workflow/way to ensure a smooth upgrade?    

Last time I did this it was pretty fussy, tried one method, failed, then I think I uninstalled Pro, hunted some hold-out folders down, deleted them, etc.  Started with a fresh install, then installed the deep learning libraries, cloned it, and was successful. Not sure if this is smartest way to upgrade this time.  

Thanks for your recommendations.

-C

0 Kudos
1 Solution

Accepted Solutions
DanPatterson
MVP Esteemed Contributor

packages for 3.3 are in the process of being addressed the week of May 27...

I would follow the advice here

Esri/deep-learning-frameworks: Installation support for Deep Learning Frameworks for the ArcGIS Syst...

unless you are in a huge rush you can continue to use the 3.2 versions according to the link


... sort of retired...

View solution in original post

2 Replies
DanPatterson
MVP Esteemed Contributor

packages for 3.3 are in the process of being addressed the week of May 27...

I would follow the advice here

Esri/deep-learning-frameworks: Installation support for Deep Learning Frameworks for the ArcGIS Syst...

unless you are in a huge rush you can continue to use the 3.2 versions according to the link


... sort of retired...
ConstantinePapadakis
New Contributor II

Thanks Dan. For anyone else also curious about my original question, the recommendation to upgrade Pro and match the compatible Deep Learning Libraries is still to uninstall Pro and the Libraries completely first, the perform a fresh install of both: 

"Important

Ensure compatibility by matching the versions of Deep Learning Libraries and ArcGIS software. To upgrade from a previous version, begin by uninstalling both Deep Learning Libraries and your ArcGIS software, following the instructions provided below.

Upgrading From a Previous Version:

If you're upgrading from a previous release, the safest way to upgrade is to uninstall and reinstall both the product and the deep learning installer. For example, to upgrade from Pro 2.8 to Pro 2.9:

  1. Uninstall Deep Learning Libraries for ArcGIS Pro 2.8
  2. Uninstall ArcGIS Pro 2.8
  3. Directly remove any files still present in C:\Program Files\ArcGIS\Pro\bin\Python\envs\arcgispro-py3 or equivalent location for your installation. These may have been left over from previously modified environment.
  4. Install ArcGIS Pro 2.9
  5. Install ArcGIS Pro 2.9 Deep Learning downloaded from this site.

After these steps, you should have a clean Pro installation with the Deep Learning package set included in the default arcgispro-py3 environment."

https://github.com/Esri/deep-learning-frameworks

0 Kudos