Read-only schema lock; project not open

138
14
05-24-2022 12:14 PM
Labels (3)
MattCotterill
New Contributor III

I have an ArcGIS Pro project that will only open as read-only. I don't have it open anywhere else and I've tried closing everything and even restarting my computer.

Before this happened, I was migrating .mxd documents to Pro projects and feature classes from .mdb databases to .gdb databases

0 Kudos
14 Replies
DanPatterson
MVP Esteemed Contributor

"Save As" to a new filename.  Does that one open as read only?


... sort of retired...
0 Kudos
MattCotterill
New Contributor III

The new version I can open and edit. the old version is still locked. Here's the message I get when I try to delete it:

MattCotterill_0-1653426916047.png

 

0 Kudos
DanPatterson
MVP Esteemed Contributor

don't know what ArcGISIndexingServer is, but by chance is there non-local data in the aprx?  If so, try remove any layers that aren't locally stored incrementally with a save after each removal to see if you can narrow down the offending data


... sort of retired...
0 Kudos
MattCotterill
New Contributor III

nope, it's all local except for the basemap

0 Kudos
SimonKedward1
New Contributor II

I'd be interested to know if deleting the index and cache works.

https://support.esri.com/en/technical-article/000012557

 

0 Kudos
MattCotterill
New Contributor III

still no dice...

0 Kudos
Robert_LeClair
Esri Frequent Contributor

Matt - let's try to disable the ArcGISIndexingServer process and see if that resolves the locked/read-only *.aprx.  To do this:

1). Close ArcGIS Pro.
2). Go to Start Menu> Search for "Task scheduler" > Open Task scheduler.
3). On the left hand pane in Task scheduler, Click on Task scheduler(Local) > Task scheduler library.
4). In the list scheduled tasks, locate the task with name like "ArcGIS Pro Indexing (Your_Username)" >Right click on the task> Disable the task.> Close Task Scheduler.
5). Reboot the machine

Once you reboot the machine, attempt to load the *.aprx in question.  What is the result?

0 Kudos
MattCotterill
New Contributor III

still read-only

0 Kudos
Robert_LeClair
Esri Frequent Contributor

Okay - next thing.  In ArcGIS Pro, go to Project-Options-Application-Indexing.  Click "Don't create index" and uncheck "Update the index periodically"  Then close ArcGIS Pro, redo the steps for Task Scheduler.  What is the result?

0 Kudos