Error when accesing SQL Server view: "Failed to retrieve a page of rows"

02-07-2023 03:38 AM
Labels (2)
New Contributor II

I've connected to a SQL database and I'm trying to load a (non spatial) table in Arc Pro v3.

The table shows up in my catalogue and I can add it to my layer list under "standalone tables" but when I try to open/view the table, the column headers load but then I get an error before any data is shown:

"Failed to load data. Error: failed to retrieve a page of rows"

I've tried adding directly from the catalogue and through the Make Query Layer toolbox, with the same result for both.

Based on suggestions in other threads, I've also added a UID column to the table view and removed spaces from column names, but still get the same result.

The table has 72,000 rows and 5 columns. It loads fine in PowerQuery and SQL Server Management Studio, so I know the credentials work. The error message doesn't contain enough information for me to pinpoint why the process fails.

Any advice would be much appreciated.

0 Kudos
0 Replies