Select to view content in your preferred language

Display dimensions of new poly, Constraints not displaying?

224
3
06-17-2024 09:11 PM
Labels (2)
DeanChamberlain
New Contributor

Hi, my work (uni) has just stopped allowing ArcMap, so I've moved across to Arc Pro.

I've imported an .mxd I was using in ArcMap to ArcPro. I do have a backup .mpk if needed, but from memory it loses all the colours etc, which with 20+ layers is annoying. 

I'm trying to draw a 50 x 20m polygon, adding to an existing layer. The dimensions are important. When I turn on the Constraints button, highlight distance as a constraint, it still doesn't display anything like it should. I've tried restarting Arc, and the computer, but nothing. You can see from the pic that the Constraints is on, but the polygon I'm drawing isn't showing anything. 

What am I missing here? Is this an artifact of bringing it across as an .mxd file?

Any suggestions appreciated. 

Thanks

 

 

Screenshot 2024-06-18 at 1.59.21 PM.png

0 Kudos
3 Replies
DeanChamberlain
New Contributor

Apologies, I can't find the edit button.

Loading the mpk file into a new map doesn't make a difference, and other layers display the constraints, so it's not across the map, it's this layer. 

0 Kudos
Robert_LeClair
Esri Notable Contributor

To create a polygon feature constrained by a distance, you can follow the directions in the help documentation here.  The Edit tab is at the top of the ribbon and is where one "starts" an edit session.

0 Kudos
JenniferCadkin
Esri Contributor

@DeanChamberlain  On-screen constraints are not available with the Rectangle tool at this time.  The Rectangle tool has constraints for Length and Width that you can access from the context menu or shortcut keys (L and W).

Another approach is using a preset template.  Once you create a polygon with the necessary dimensions, create a preset template from the feature and use it like a stamp to place additional features.  Click here to learn more.  

0 Kudos