Create Map Tile Package creates empty output

341
5
Jump to solution
01-27-2022 03:36 AM
Labels (2)
StefanBrandt
New Contributor II

I'm trying to create a TPK from my Raster-Dataset

While the Raster-Dataset is about 500 megabyte large, the output that is created by the aforementioned tool is only about 500 kilobytes large. Needless to say nothing is displayed when I load this Tile Package into anything.

The Map has the correct coordinate system (for the ArcGIS Online Tiling Scheme), I tried out all the Tiling Formats, changed the Level of Detail, Extent, Compression Quality and Package Type but the results remain the same.

 

Since the Tool does not generate any Errors or Warnings I am left without any idea of how to fix this.

 

Any help would be appreciated!

0 Kudos
1 Solution

Accepted Solutions
rzufelt
Occasional Contributor

Have you tried in Pro, Share menu, Web Layer, Publish Web Layer?

I have had much better success using this menu option to generate tile packages than the GP tools in Pro.

Also, if you have any text or linework in your basemap, this is the only option in Pro to maintain the antialiasing options and produces a much nicer product.

 

R_

View solution in original post

5 Replies
DanPatterson
MVP Esteemed Contributor

Create Map Tile Package (Data Management)—ArcGIS Pro | Documentation

your map has a description and tags?

what service type?

Old "bugs" suggest that nothing will be created if rasters don't have pyramids or statistics built

Problem: The Create Map Tile Package tool returns incomplete map tiles in ArcGIS Pro (esri.com)

BUT this bug for arcmap says it applies to Pro

BUG-000116636: A tile package (.tpk) created from Create Map Tile P.. (esri.com)

sounds like your situation


... sort of retired...
0 Kudos
StefanBrandt
New Contributor II

It has descriptions and tags and I also calculated pyramids and statistics for it.

 

I'm using the default ArcGIS Online/ Google Maps Service.

0 Kudos
DanPatterson
MVP Esteemed Contributor

That leaves the remaining suggestion from the links, or you can check for others on the support site

Esri Support | ArcGIS Technical Support

or contact Tech Support directly to see if they have other unlisted suggestions


... sort of retired...
0 Kudos
rzufelt
Occasional Contributor

Have you tried in Pro, Share menu, Web Layer, Publish Web Layer?

I have had much better success using this menu option to generate tile packages than the GP tools in Pro.

Also, if you have any text or linework in your basemap, this is the only option in Pro to maintain the antialiasing options and produces a much nicer product.

 

R_

daygeckoart
New Contributor

I have the same problem. Totally blank tileset although it's about 20 megabytes  https://daygeckoart.maps.arcgis.com/home/item.html?id=d2ce47a2c1354f4e94204fcf22f1472b#overview

0 Kudos