Copy parallel arc segment converted to line segments

86
5
05-24-2022 04:09 AM
Labels (1)
LStappaerts
New Contributor II

Hi,

I have a problem with the copy parallel command in ArcGIS Pro (2.9 installed version). When I want to copy parallel a polyline which has an arc segment in it, then the arc segment in the copied polyline is reduced to straight segments.

I suspect it has to do with the XY resolutiuon and tolearance of the feature class (polyline features class stored in a file geodatabase), but strange enough I am able to draw a comparable arc segment with the editor itself without the editor converting my arc segment to a line segment.

Anyone else having this problem or a solution to solve it?

Thanks.

0 Kudos
5 Replies
Scott_Harris
Esri Regular Contributor

Hi @LStappaerts 

You mention that you suspect the resolution and tolerance of the feature class could be a cause, can you provide more details on what those are? Is the map in the same coordinate system?

Thanks!

0 Kudos
LStappaerts
New Contributor II

Hi Scott,

The coordinate system of the map is the same as the coordinate system of the feature class : Belge Lambert 1972 (WKID = 31370).

These are the values for resolution and tolerance

LStappaerts_0-1653407823649.png

Thanks.

Scott_Harris
Esri Regular Contributor

Thank you, @LStappaerts. Those look like reasonable values for resolution and tolerance.

  1. What scale are you working?
  2. How long are the segments?
  3. What do the features represent?
0 Kudos
LStappaerts
New Contributor II

The segments in the example are approx. 2,5 meters long. The features represent part of a road, in this case a cycle path.

Scott_Harris
Esri Regular Contributor

@LStappaerts Thanks for the additional info. The development team is investigating the issue. If I have any further info, I'll let you know.

0 Kudos