Clip raster freezes Arcgis pro

231
11
2 weeks ago
Labels (2)
saidurgamalleswarthota
New Contributor III

I'm using clip rater to clip USA population data with polygon shapefile of USA Counties with the help of a model builder.

If I check the box of "Use Input Features for Clipping Geometry" then Arcgis is freezing for some polygons.

If I uncheck that box, everything is fast and smooth. The operation was successfully completed.

I tried using "if field value is" in the model builder to exclude that specific polygon which is causing acrgis to freeze like "71". But again I'm having the same problem with another polygon like "84". I can't just keep on finding the troublesome polygon like this. Totally there are more than 3000 polygons.

If I "use Extract by mask" it takes too much time to complete the whole process.

Anyone, please tell me what is the problem and how to deal with this.

I have to use "Use Input Features for Clipping Geometry".

 

0 Kudos
11 Replies
DanPatterson
MVP Esteemed Contributor

Check Geometry first

Multipart toDinlepart second

your clipping geometry may have issues OR it is too complex for those shapes you identified


... sort of retired...
saidurgamalleswarthota
New Contributor III

If I do the multipart to single part then all the islands are divided into individual polygons. I won't be able to figure out which islands combine to form one county.

check geometry is showing no problems. There is nothing in the table.

Please tell if you want me try something else

0 Kudos
SteveLynch
Esri Regular Contributor

use CheckGeometry and use the OGC validation method if the default validation method takes too long.

0 Kudos
saidurgamalleswarthota
New Contributor III

check geometry is returning none. I don't know what to do now.

Please suggest any ideas. Thank you.

0 Kudos
DanPatterson
MVP Esteemed Contributor

multipart to singlepart? did you check that? there are sometimes issues handling multipart features

perhaps a screengrab of the offending file is needed


... sort of retired...
0 Kudos
saidurgamalleswarthota
New Contributor III

Could you please explain how to check multipart to single part? I'm new to Gis. 

I only saw the conversion of multipart to single-part. I didn't understand how that will help me to clip the raster.

Please help me how to check the multipart to single-part. I checked with check geometry. I got "could not find spatial index at -1" Then I used "add spatial index". Then again checked Geometry.

Screenshot 2021-11-27 123647.png

 Still If I use clip raster and check the box of " use clipping geometry" The process is  getting freeze at some polygons.

 

 

0 Kudos
DanPatterson
MVP Esteemed Contributor
0 Kudos
saidurgamalleswarthota
New Contributor III

Also multipart to single is also not working. clip raster again froze at same polygon everytime it did with normal shapefile.

saidurgamalleswarthota_0-1637987996848.png

 

0 Kudos
saidurgamalleswarthota
New Contributor III

clip rater is successful when I do it only that one polygon(69.tif)

But using the model builder it's getting stuck at "69.tif" as shown in the above screenshot.

0 Kudos