Can no longer delete selected rows in attribute table

94
2
09-28-2022 06:52 PM
Labels (1)
PaulMatsui
New Contributor

Hi - I recently have encountered a situation where I can no longer delete rows within the attribute table of a new layer I've created after doing a spatial join. I used to be able to select all rows that I wanted to remove through the Select by Attributes feature and then hit Delete, but now my delete button is grayed out. I feel like I may have inadvertently hit a button that has made these tables read-only when they're created, but can't figure out how to make it editable. Have been searching for a solution but have come up empty. I did recently upgrade to Pro v3.0.2, but not sure if it's that or if I changed a setting. Any help appreciated!

0 Kudos
2 Replies
PaulMatsui
New Contributor

In continuing to try different things, I believe I have resolved this issue, apologies. For whatever reason, the Adding a spatial join by right clicking a table from the contents menu yields a different spatial join menu than hitting spatial join from the Analysis tab (see attached). And doing so by right clicking the table from the content menu makes the resultant table read-only in an irreversible way, while the other way makes it editable as I've been used to. Is this a change in v3.0.2?  

In any case, sorry but I've resolved my issue, just confused as to why the spatial join actions are different depending on how you get there. Thanks

0 Kudos
DanPatterson
MVP Esteemed Contributor

some shortcuts invoke arctoolbox tools

Add Spatial Join (Data Management)—ArcGIS Pro | Documentation

Spatial Join (Analysis)—ArcGIS Pro | Documentation

some create a permanent join, others temporary, the difference will affect what can be edited amongst other things.  


... sort of retired...
0 Kudos