Cached map service draws very slow in ArcGIS Pro map

109
2
12-02-2021 08:30 AM
LeeBrannon1
New Contributor III

I had just published a cached map service from ArcGIS Pro 2.9 (also had tried this in 2.8 a week earlier) to ArcGIS Server 10.9, which went perfectly fine.  This particular cached map service is in a State Plane coordinate system.   When I pull that cached map service into a blank map in ArcGIS Pro, it draws very slowly, as if it is not using the cache tiles, or if it is using the tiles, they are being drawn very slowly for some reason.  When I add an older cached map service (created from ArcMap 10.7.1 and located in ArcGIS Server 10.7.1) to this same ArcGIS Pro map - a cached map service which is projected in Web Mercator (Auxiliary Sphere) - it redraws very fast, as you would expect from a tile cache.  The two cached map services being tested here are the same aerial imagery mosaic.  

So I'm just wondering how to get my State Plane cached map service to draw as quickly as the Web Mercator version of the service in an ArcGIS Pro map. ??   They both draw equally fast in the ArcGIS JavaScript viewer as well as in ArcMap 10.8.1.  What is it about the cached map service not being in Web Mercator that would make the tiles so slow to draw in ArcPro? 

I don't think the issue is with ArcMap vs ArcPro, nor with the version of ArcGIS Server or anything such as that.

0 Kudos
2 Replies
AmyRoust
Occasional Contributor III

Are you adding your State Plane cached service to a map that already has a different projection set? Perhaps Pro is working overtime to reproject your service to the local map's projection on the fly?

0 Kudos
LeeBrannon1
New Contributor III

I thought that the map projection could be an issue, so I made sure to test it in a map that has the same State Plane projection as the service.  But it was still slow.

In fact, when I add a Web Mercator (Aux Sphere) cached map service to my State Plane map in ArcGIS Pro, it is still very quick to draw.

Thanks though.

0 Kudos