ArcGIS Pro 2.8.3 python paquetage loading issue

49
0
09-16-2021 07:05 AM
Labels (1)
Rémy_Gourrat
New Contributor II

hi,

In ArcGIS Pro 2.8.2, i have a toolbox instantiate psycopg2 2.8.5 fine.

In ArcGIS Pro 2.8.3, the same toolbox instantiate the psycopg2 2.8.6 but loaded with failed.

I i tried to uninstall the psycopg2 2.8.6 and install 2.8.5, each time 2.8.6 is coming back, question of dependencies i think...

When i check the code i have this message :

Traceback (most recent call last):
File "<string>", line 6, in <module>
File "C:\Users\Administrateur\AppData\Local\ESRI\conda\envs\arcgispro-py3-clone\Lib\site-packages\psycopg2\__init__.py", line 51, in <module>
from psycopg2._psycopg import ( # noqa
ImportError: DLL load failed: Le module spécifié est introuvable.

Can you help me ?

Thanks 

Rémy

 

0 Kudos
0 Replies