Expose Selection Mode Hotkey Behavior as User-defined Setting

160
5
3 weeks ago
Status: Open
Labels (1)
jcarlson
MVP Regular Contributor

As of the latest update to Pro (2.8.3), the behavior of the selection mode hotkey (Y) has changed.

Before

Pressing Y with the Selection tool active was equivalent to toggling this setting:

jcarlson_0-1632759309196.png

Pressing Y once in a selection "session" would toggle the selection mode for all subsequent edits in the same session. Pressing it again or deactivating the selection tool would revert the selection mode back to the default behavior as defined in the user's application settings.

After

Pressing Y with the Selection tool active toggles the selection mode only while the key is held.

Why this Matters

From a usability perspective, what once only required the use of a single hand now requires simultaneous use of both. That can be tricky if I am on the phone or holding my infant son (working from home!), for example.

Additionally, I am often using the hotkey to toggle selection modes for a series of selections. Most commonly, I am cleaning up parcel fabric points and line features, when it is helpful to select "fully within". I may be doing this sort of work for 15 minutes at a time. Before, I could press Y once at the beginning of this work and proceed, but now I've got to either change the application settings or else use both hands for every selection I want to make.

Finally, I've noticed inconsistent behavior trying to combine the "hold-down" hotkey and the Ctrl and Shift keys, making it harder to get precisely what I want to select.

Proposed Solution

I do like having the "hold-down" behavior in certain circumstances, so I don't just want to revert this back to what it was like in 2.8.2.

What I envision as the ideal solution is to give users control over this behavior:

Selection settings with hotkey behavior exposedSelection settings with hotkey behavior exposed

 

Tags (2)
5 Comments
jcarlson

Ah, y'know what, this can be closed. I accidentally discovered that Alt+Y does what Y used to do.

This section of the keyboard shortcuts page just needs to be updated:

jcarlson_0-1632847492348.png

 

KoryKramer

Hi @jcarlson The idea is valid but you have us scratching our heads so I just wanted to clarify a few things.

1. Alt+Y was never an option so we don't believe anything broke between 2.8.2 and 2.8.3.  I tested, and we've run this by the development team and they are unaware of Alt+Y functionality - and none of us can reproduce the action that you are describing.

2. Meaning that to follow up on your reply that the doc should just be updated... we don't want to do that since as far as we know, this shouldn't work :)  

3. If you or @RandyCasey or @שלומיחזאם who are upvoting this can provide any further information about how you are getting Alt+Y to work, that might be helpful.  

As for now, the expected behavior is that you need to hold down Y while making the selection to switch the mode and should receive visual feedback in the sketch:

Not holding Y:

KoryKramer_0-1632943663148.png

Holding Y:

KoryKramer_1-1632943686786.png

 

 

jcarlson

@KoryKramerWell, that's really odd. Alt+Y does exactly what I am looking for, but who knows why? If it's some anomaly that I'm experiencing (on multiple Pro installations, by the way), then I'd much rather just have an official solution to this.

I guess disregard my comment about the alt key. If it matters, it actually seems to be Y+Alt, somehow the order matters?

Here's a recording:

  1. I drag a selection box and press and release Y a couple times. Normal behavior.
  2. I press Alt+Y, then do the same thing. Toggled behavior.
  3. I press Alt+Y once more, repeat. Normal behavior has returned.

FqoxsAyFiN.gif

jcarlson

Maybe hitting Alt, which normally opens up the keyboard commands, makes the Y-hold "stick" by interrupting the interface in some way?

jcarlson_0-1632944533636.png

The oddest part is that it persists for more future selections, but nowhere else in the application does it behave as though the Y key is being held.

KoryKramer

Thanks, @jcarlson For whatever bizarre reason, it does appear that Y+Alt toggles it.  Alt+Y does not do it for me, but Y+Alt does.