Allow the user to set the default units for curves in the Traverse tool

05-20-2021 01:04 PM
Status: Already Offered
Labels (1)
MVP Honored Contributor

Every time I create a new course in the Traverse tool for a curve the units reset to decimal degrees (dd) for the Delta Angle.  Unlike the line symbol choice that remembers the symbol for the next course, the Delta Angle resets for every newly created course.  I always enter the Delta Angle in Degrees Minutes Seconds (dms) units so I am constantly having to change this setting for every curve course I create.  If I fail to change the units from dd to dms and enter the value as a dms value, the tool treats the dashes like minus signs and completely changes the value.  This error causes the tangent bearing of the next course to be wrong and I have to press the undo button to remove the Delta Angle value so I can change the units, enter the dms value and set the correct course.  Switching from keyboard to mouse to change the units for every curve course slows the whole process to a crawl. 

I presume the units are internally stored in dd units, since every time I enter a dms value and exit the Delta Angle field, the value and units are displayed as dd units.  However, if I click on the value to edit in the Delta Angle it remembers the units I previously chose and changes the value and units back to dms.  If I change the unit to ra it remembers that choice as well.

I would like a way to set the default Delta Angle units to dms the first time I enter the field for editing for every new course I create in the Traverse tool.  It can still display dd units when I am not editing in the field.  It should then continue to remember any changes I make to the units for the next time I enter the field.

This would save considerable time and along with my other idea to set a default Line symbol this change would make the traverse tool a keyboard only tool from the starting course to the ending course and for every new single course traverse I create.  

Status changed to: Needs Clarification


Using ArcGIS Pro 2.8 you can change the angular default units from decimal degrees to DMS:


Then to enter a delta angle in the traverse you have 2 options. The first is to use the 'd' override for 'd'elta angle. It will continue to show the 'd' override and respect the dashes as separators (not a minus sign for substraction):


The second option is to change the column header to Delta Angle. If you set your project anular units to DMS it will pic it up as the default:



Regarding how the values are stored on a 'COGO Enabled' line feature class: directions are stored in decimal degrees north azimuth, distances and radiuses are stored in the units of the spatial reference (for PCS), To define a curve radius and ArcLength are stored.

So if you define the curve using radius and chord length or radius and delta angle it will still store it as ArcLength. If you want to also store a delta value for curves you can use an attribute rule (just make sure to only calculate it if the radius bigger than zero):

// return delta angle in degrees given a radius and arclength
var r = 1; //radius
var al = 3.14159; //arclength
var delta = (al/r)*(180/PI);
return delta;



I am using ArcGIS Pro 2.7, and out of the box it behaves the way I described, but it does have the Option Angular Units setting so I tried that.  That resolved the issue.  But I am glad to hear that ArcGIS Pro 2.8 has fully fixed this issue for those like me who didn't think to look at the Angular Units Option.  I tried installing 2.8 yesterday, but it failed.  I will contact Esri support to get that resolved.


I look forward to the version where the default line symbol can be set for the initial course of each new traverse, since my Idea for that is in the product plan.


Thanks @RichardFairhurst 

This has always worked for the traverse in ArcGIS Pro. 

The comment I've made regarding "using ArcGIS Pro 2.8"  was designed to make sure we are comparing "apples to apples". So make sure to set your project unit settings.

Regarding the missing symbol of the feature template when for the first course of the first entered traverse  - we plan to fix this bug.


Status changed to: Already Offered

The traverse tool has always respected the project unit settings for direction, distance, and  angles