There was an error publishing the service.

195
1
02-08-2023 02:59 PM
SamanthaEarnest1
New Contributor II

I have created a feature layer from an Excel spreadsheet. I spent a lot of time adding multiple attachments (photos) to each point in the layer after it was created. I then made a Web Map and Instant App using the layer. This worked fine for several weeks. I need to update the layer now, but I am unable to do so because I keep getting the message, "There was an error publishing the service." when I click on the feature layer in my Contents area. I am unable to access any settings for the layer. I have tried deleting the layer from the Web Map, but I still get the error message. I am able to add it back to the Web Map with no problem, and the data is all still visible in the Web Map; I just can't access the feature layer itself in order to edit it. This is the second time I have had this same issue.  I cannot afford the time involved to recreate the layer a third time.

My question is: is there a known issue that would cause a hosted feature layer to cease being editable after either a certain length of time, or a certain number of interactions with the layer (number of views or clicks on the popups?) Why can't I go back in and edit this layer, when I've been able to before? I don't believe it's anything to do with the size of the layer (size or number of photos) because it has been working and the file size has not changed. 

1 Reply
VojtěchAndrš
New Contributor

Hello, I have the same issue. Feature layer used in Dashboards, works fine for some time and then this error quote appears with no possibility to go into data or settings tab. Have you found any solution besides recreating the layer?

0 Kudos