Print/Export offsets layers

116
5
Jump to solution
08-13-2022 07:49 AM
GrayElkington
New Contributor

When I export a file from Print, the five sketch layers are all offset to the right by 140 metres.

The attached image shows the layers offset.

I'm hoping there's a simple solution!

Your ideas welcome.

0 Kudos
1 Solution

Accepted Solutions
Noah-Sager
Esri Regular Contributor

Hi @GrayElkington, sorry to hear about the printing trouble. Is this using the Map Viewer? My hunch is that the layers are sent as a screenshot because of the layers effects, and there is some padding/offset in the map. If this is the case, then this is a known issue that we are currently working on resolving for the upcoming release.

Documented as a known limitation here: https://developers.arcgis.com/javascript/latest/api-reference/esri-rest-print.html

 

View solution in original post

5 Replies
GrayElkington
New Contributor

Further intel: The fault manifests in both Safari and Chrome (both are up to date) running on macOS Monterey 12.5. 

Out of over two dozen attempts to export, two have rendered properly with the layers in the correct position. I have variously rebooted, manipulated the layers and refreshed the webpage but haven’t been able to determine why two exports worked just fine.

The layers are offset whether exported to PDF or PNG32.

0 Kudos
GrayElkington
New Contributor

Although I have managed to export two maps without any offset, I'm still in need of a permanent fix.

In my original post, I related the offset to the underlying map, saying it was off by 140 metres. In fact, the offset has nothing to do with the map. At different zoom levels, the offset remains at 4cm as measured on my screen.

0 Kudos
GrayElkington
New Contributor

I have just downloaded and used Firefox... but still the layers are offset in the same way.

0 Kudos
Noah-Sager
Esri Regular Contributor

Hi @GrayElkington, sorry to hear about the printing trouble. Is this using the Map Viewer? My hunch is that the layers are sent as a screenshot because of the layers effects, and there is some padding/offset in the map. If this is the case, then this is a known issue that we are currently working on resolving for the upcoming release.

Documented as a known limitation here: https://developers.arcgis.com/javascript/latest/api-reference/esri-rest-print.html

 

GrayElkington
New Contributor

Thanks so much for coming back to me and, yes, it happens while using Map Viewer.

Your hunch is correct. The developers site you linked to has a list of Known Limitations including: There is no current support for printing highlighted features.

This prompted me to turn off the Bloom Effect within all five layers and now the layers export every time perfectly aligned to the underlying map. 

And as further confirmation, if I turn the Bloom Effect on within one of the five layers, it alone misaligns, while the other four (with Bloom turned off) remain aligned.

I'm very pleased to have cracked that problem - with your kind help!

0 Kudos