I can't upload a hosted feature layer

304
3
Jump to solution
02-22-2024 08:39 AM
Labels (1)
FrancescoCotana
New Contributor II

 I have a GIS Professional Advanced license and I have a Administrator Role. I've followed these guidelines:
https://doc.arcgis.com/en/arcgis-online/manage-data/publish-features.htm
But still I can't upload the file as a hosted feature layer.
I'm attaching the xlsx file for reference.

I've tried with any kind of file and I think its not a problem of the formatting or the file.

Please help me I don't know what to do

Thank you very much

Tags (1)
0 Kudos
2 Solutions

Accepted Solutions
MiguelParedes
Esri Contributor

Greetings @FrancescoCotana 
I have added your .xlsx file to my content by dragging and dropping the file and I have been able to publish it as a hosted feature layer:

MiguelParedes_0-1708674856727.png

After uploading the Excel sheet, ArcGIS Online recognised the coordinate fields, so I used those:

MiguelParedes_1-1708675318450.png

Would you try again and see if that works for you?

Miguel

View solution in original post

FrancescoCotana
New Contributor II

Hello,

Thank you for your help, 

I've tried again this morning at it worked. I don't know what might have been the problem, because I had also tried last night before closing the program. For other users that might have the same problem, something that I did yesterday, that might have been useful was enabling all my add-on licenses. In particular Publisher might have been the one I had to enable. I did try uploading the file after enabling these licenses and it didn't work, but it did this morning, maybe some time was needed.

Thank you very much for your help.

View solution in original post

0 Kudos
3 Replies
DavidPike
MVP Frequent Contributor

What error message are you getting?  Your Lat and Lon fields show an error.  Do you just want to upload a table?

MiguelParedes
Esri Contributor

Greetings @FrancescoCotana 
I have added your .xlsx file to my content by dragging and dropping the file and I have been able to publish it as a hosted feature layer:

MiguelParedes_0-1708674856727.png

After uploading the Excel sheet, ArcGIS Online recognised the coordinate fields, so I used those:

MiguelParedes_1-1708675318450.png

Would you try again and see if that works for you?

Miguel
FrancescoCotana
New Contributor II

Hello,

Thank you for your help, 

I've tried again this morning at it worked. I don't know what might have been the problem, because I had also tried last night before closing the program. For other users that might have the same problem, something that I did yesterday, that might have been useful was enabling all my add-on licenses. In particular Publisher might have been the one I had to enable. I did try uploading the file after enabling these licenses and it didn't work, but it did this morning, maybe some time was needed.

Thank you very much for your help.

0 Kudos