HTML Format for clickable hyperlink in popup table

141
2
Jump to solution
10-05-2022 03:58 PM
RaenaDeMaris
New Contributor III

Hi all, In AGOL, I've configured a custom popup with attribute expressions and was asked to add websites to the popup, if that info is populated in the attribute table. The website displays as expected, but it's not a clickable link. How might I solve that? My code for my conditional Arcade expression and the HTML formatting for the popup are below along with an image of the popup: 

RaenaDeMaris_0-1665010642843.png

//website conditional {expression/expr38}
Iif(IsEmpty(Trim($feature.Website)), "none", "table-row")
 <tr style="background-color:#657078;display:{expression/expr38};" valign="top">
                                                                            <td style="border:1px solid rgb(203, 203, 203);padding:2px;">
                                                                                <span style="color:#FFFFFF;font-family:Arial;font-size:10px;"><strong>Waterkeeper Website</strong></span>
                                                                            </td>
                                                                            <td style="border:1px solid rgb(203, 203, 203);padding:2px;">
                                                                                <span style="color:#FFFFFF;font-family:Arial;font-size:10px;"><strong>{Website}</strong></span>
                                                                            </td>
                                                                        </tr>

 Many thanks for any assistance or insights you can provide.

rbd
0 Kudos
1 Solution

Accepted Solutions
JohannesLindner
MVP Regular Contributor
<a href="{Website}" target="_blank">{Website}</a>

Have a great day!
Johannes

View solution in original post

0 Kudos
2 Replies
JohannesLindner
MVP Regular Contributor
<a href="{Website}" target="_blank">{Website}</a>

Have a great day!
Johannes
0 Kudos
RaenaDeMaris
New Contributor III

@JohannesLindner Thank you, that worked (of course). I also realized that I could simply put {Website} in the "URL" parameter in the GUI formatting of the text block. Sometimes I choose the more difficult course. But now I know, so thank you!

rbd
0 Kudos