Select to view content in your preferred language

Feature layer change log - how to view previous versions / history

203
1
05-16-2024 10:05 PM
jakubk
by
New Contributor

I'm testing the change log option for hosted feature layers but I don't think i'm using it properly so after some advice

Change tracking in a database should tell me 5 things

what was changed
who changed it
when they changed it
how it was changed (before/after)

but i'm not able to get all this info out of arc online - it just gives me the changed/current version without specifying which field was changed or what it was originally

 

How do i use the extractChanges api call so I can answer "what changes did this person make?"

 

I've done some other testing like trying to use the fieldsToCompare (didn't work - returned data even when comparing on fields i didn't change)

and changing the same field back and forth between 2 different values - it didn't capture any of the intermediate changes either.. just returns the current value.. what's the point of that?

My process:

I've uploaded/published a test fgdb to a hosted feature layer. I've turned on editing and change tracking

I modify one of the fields in an attribute table

followed this guide - How To: Extract Changes from the Change Tracking Table (esri.com) & api reference - Extract Changes (Feature Service)—ArcGIS REST APIs | ArcGIS Developers

(i just put in the layerIDs i was interested in and the minServerGen and serverGen I pulled out from the metadata call - left everything else default)

I'm able to make the rest call and get a json output and yes, it has the 'row' i modified, but it only shows the current/changed version. There's no corresponding record of the original

I also tried by running the call using a minServerGen of 0 and serverGen 999999 to make sure it would grab any/all versions

 

Surely agol keeps the original version, otherwise how would it know what's changed

I also tried using the fieldsToCompare option but the api returned the row even when i set it to compare a field i didn't change

 

 

0 Kudos
1 Reply
PhilippNagel1
New Contributor III

Were you able to get anywhere with this? I am running into the same issue.

0 Kudos