Building to ios using SDK 1.3

421
6
Jump to solution
12-06-2023 04:51 PM
ChrisRenzi
New Contributor

Hi,  I'm trying to build my app to ios and I'm getting linker errors for missing binaries.  If you look at the package content from the ArcGIS package puleed from the Unity asset store, under the binaries folder, ios is missing.  Any idea where to get the ios binaries or can I build them locally?  

 

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
Samuel_Cartledge
New Contributor

Hello,

It looks like there may be an issue with the iOS binaries in our plugin that is found on the Unity Asset store. For now, I would recommend fixing this by downloading the plugin from our ArcGIS Developers page here: https://developers.arcgis.com/downloads/#unity . We will look into the issue with the Unity Asset store, thank you!

View solution in original post

0 Kudos
6 Replies
ChrisAnderson7
New Contributor
This might help

<>
Unity IssueTracker - Building projects with IL2CPP scripting backend for Apple platforms fails with Xcode 15.0b6 or newer<>
issuetracker.unity3d.com<>
[U_Favicon_Grey_512x152-43ff9e6db51a9610787d87f9df4524d693ebd1c47a7650a1e4d63be5ffdf3797.png]<>

0 Kudos
ChrisRenzi
New Contributor

Thanks for the response.  I'm actually using Xcode 14.3.1

0 Kudos
ChrisRenzi
New Contributor

To be more specific, the errors are:
Undefined symbol: _RT_AngularUnit_ConvertFrom
Undefined symbol: _RT_AngularUnit_ConvertTo
Undefined symbol: _RT_ArcGISRuntimeEnvironment_enableLeakDetection
and about 120 others.
I believe I am just missing the runtime binaries.

0 Kudos
Samuel_Cartledge
New Contributor

Hello,

It looks like there may be an issue with the iOS binaries in our plugin that is found on the Unity Asset store. For now, I would recommend fixing this by downloading the plugin from our ArcGIS Developers page here: https://developers.arcgis.com/downloads/#unity . We will look into the issue with the Unity Asset store, thank you!

0 Kudos
ChrisRenzi
New Contributor

I actually tried importing the tarball a couple of days ago, but didn't realize during the import there was an error overwriting some files.  Once I removed the ArcGIS package and re-imported using the tarball, it works.  The binaries are definitely missing in the package from the asset store.
Thanks for the help.

0 Kudos
Samuel_Cartledge
New Contributor

Glad to hear it works, and yes, I see they are somehow missing from the build we have on the Asset Store...

0 Kudos