Add Content: Add Layer from file

199
8
10-15-2021 11:25 AM
PaulFyfield
New Contributor II

I am experimenting with adding layers from file in Illustrator. I teach a cartography class and we've been using M4CC to open AIX files exported from Pro. The map extent is of the San Juan Islands in Washington state. Now I want my students to add a KML file of the ferry lines after the map is exported. I clipped and projected the ferry data, hoping to speed up the import, before creating the KML. The AIX displays the correct extent in the Mapboard window, which is awesome. It also sees the larger extent of a location map that was also in the APRX layout. However the KML import (using "Add Content: Add Layer from file" in the Compilation window, then syncing) hits about 99% with the "Preparing layers, please be patient, we're still working" message just not disappearing. I've let it run for hours. Is this a bug, or am I doing something wrong? I can't find information on the web specific to this issue. Software used is ArcGIS Pro 2.8, Adobe Illustrator CC 2020, and M4CC 3.0.

0 Kudos
8 Replies
XingdongZhang
Esri Contributor

Hello PaulFyfield,

Sorry for the inconvenience. Could you please share the KML file that you try to import? If possible, please also share your ArcGIS Pro project file. We will investigate the issue that you encountered.

Thanks for using Maps for Adobe in your class. We love to hear Maps for Adobe app is a helpful tool for your cartography teaching. Please let us know if you have any questions. If you have any idea for the future improvement of our product, please share it on site https://community.esri.com/t5/arcgis-maps-for-adobe-creative-cloud-ideas/idb-p/arcgis-maps-adobe-clo...

Xingdong

Maps for Adobe Team

 

 

0 Kudos
PaulFyfield
New Contributor II

Thanks Xingdong. The APRX and GDB are probably too large to attach- they contain all the course exercises, including some raster data. I tried attaching the KML and AIX files, but I get an error saying that the file type is not supported. What's the best way to get them to you?

Paul

0 Kudos
XingdongZhang
Esri Contributor

Hello PaulFyfield,

Could you please attach the KML file first? If we can't reproduce the issue in-house with the kml file only, we may find a way for you to upload the APRX file.

Thanks,

Xingdong

0 Kudos
PaulFyfield
New Contributor II

Okay Xingdong, I figured out how to attach files by zipping them. Here are an AIX, AI, and KML file.

The AIX file is a straight export from the APRX. This is a text placement exercise, where students chose fonts and label placement for 50 GNIS features in the San Juan Islands. The AI file is what that exercise could look like completed. What I would like the class to do for a later exercise is add the ferry lines by importing a KML file, which is also in the zip file. The AIX file contains a second map frame for the location map, which I have deleted from the AI file, since the location map was repositioned. When I go to "Import-from File" the ferry lines pop right into place in the map board, but when I sync it just grinds and grinds for hours. It creates a temp file but just never finishes the import. I can try attaching a zip file of the APRX and GDB files too but I'm afraid the file size will be too large.

0 Kudos
Anna_Breton
Esri Contributor

Hey there @PaulFyfield ,

I took a look at your files with Maps for Adobe 3.1 on a MacOS with Adobe Illustrator version 26; everything worked well for me. Curious if you could give a little bit more info on how your environment is set up? Your OS and specific Illustrator 2020 versions would be very helpful to pinpoint your issue.

Thanks!

Anna

 

0 Kudos
PaulFyfield
New Contributor II

Thanks Anna.

I'm having the exact same problem when I'm on my work computer logged into my BLM account and when I'm using my personal computer logged into my Portland State account, so I suspect the problem may be more related to "user error" on my part. I have different versions of Illustrator on the two computers, but in both cases I'm using M4CC 3.0 (and upgraded and tried 3.1 as well). Both accounts are ArcGIS Online. Here's my process:

1. I export the AIX from the APRX file

2. In Illustrator, I log into my account and open the AIX. I re-do the symbology and text placement. I reposition the scalebar and location map, and add the north arrow and title. I delete the Map Frame for the location map.

3. I have tried both "Import-From File" in the Mapboard window and "Add content-Add layer from file" in the Compilation window. I browse to the KML file. Both seem to do the same thing, and add the layer to the Compilation window.

4. I delete the base map from the Compilation window.

5. I click "sync."

6. Then it grinds, hits 99% and gets hung up. I've let it run overnight.  If I kill the temp file but save it, the data- or at least some of it- is in there. 

Is there something you can see here that I'm clearly doing wrong?

Thanks,

Paul

0 Kudos
Anna_Breton
Esri Contributor

Hey @PaulFyfield! Thanks for getting back with your workflow details, it's super helpful! Can you try one thing for me? After you add your KML file, don't delete the basemap in the compilation window, then try syncing it. Let me know if you get the same result. Either way, your workflow looks very reasonable. This looks like it may be related to a known bug on our side. 

-Anna

0 Kudos
PaulFyfield
New Contributor II

Thanks Anna, I tried that (leaving in the basemap), and I got the tool to run, but I do continue to have issues. Sometimes I get a message that the sync was successful "with errors" and other times, rather than add the KML to the existing AI, it creates a new one with a different extent. I assume this is a projection issue? Maybe because I'm using a projection that's modified and not in your list?

Since you got it to work, would you mind sharing your exact workflow? Or pointing me to a website that goes over all the dos and don'ts?

Thanks. I'm determined to get this to work.

Paul

0 Kudos