Select to view content in your preferred language

Zone lookup issues

281
5
06-10-2024 02:36 AM
Labels (1)
AileYG
by
New Contributor III

We are upgrading Enterprise from 10.8 to 11.1, and I'm trying to configure a zone lookup instant app, just like the configurable app we have in the previous portal. I'm using the same map as before, where I want to show results from 3 diferent (non-overlapping) polygon layers . But somehow the new instant app is showing the same pop-up 3 times as result, instead of once. Is this a known bug? is there any workaround for this?

The polygon layers are also doing something strange on the app, I have transparency on them and it looks fine when I configure the webmap, but in the app it starts to render the poligons darker and darker, until I looks like they overlap several (3?) times on the map. 

Any ideas on what could be wrong, and what to look for to fix it?

0 Kudos
5 Replies
KellyHutchins
Esri Frequent Contributor

Is it possible to share the map/app either the old version or new so I can take a look?

0 Kudos
AileYG
by
New Contributor III

You may take a look on the "old" app, as it is for public information. Though the new one is not shared yet, as we are still configuring the portal. Could it be the portal issues we have with the server, that is causing the problem with the app? 

https://gis-portal.forsyningen.dk/portal/apps/InformationLookup/index.html?appid=5852276ae890444d9b0...

0 Kudos
KellyHutchins
Esri Frequent Contributor

It looks like your public app (the old one) is using a configurable app named Information Lookup. Zone Lookup is an updated replacement app for that older app. You'll need to configure it to have the behavior you would like. Based on your description I think you only want one layer to show so you'll want to go into the Zone Lookup configuration experience and in the Zone Lookup section choose Options then "For a zone" and select the layer that you'd like to be in the results. 

0 Kudos
AileYG
by
New Contributor III

That's what I did in the new portal, I created a zone lookup (instant app). But I need to choose 3 diferent zones in the results. The issue is that the same result comes 3 times, even though they are separate zones.

AileYG_0-1718173542345.png    AileYG_3-1718177016322.png

And then there is the problem with layer rendering, it should look like on the left, but after a minute it ends up looking like on the right. Any ideas on what could be happening there?

AileYG_5-1718177068553.png

 

 

 

   

 

 

 

0 Kudos
KellyHutchins
Esri Frequent Contributor
Can you provide an example of a search term that returns three duplicate results? I am testing and don’t see that behavior in my demo app. Also if I look at the web map in the ArcGIS Online Map Viewer it matches the app and looks like the image on the right. I do not see the map symbology looking like your image on the left in either the app or the map viewer.

0 Kudos