Missing logo in header - chart viewer instant app

219
6
Jump to solution
11-03-2021 07:11 AM
SaraKidd
Occasional Contributor

I've created a chart viewer instant app. The logo is missing and just shows the placeholder image and text which runs into the title in the header. I know it's in beta so I'm not sure if it's the app or on my end. I have a logo uploaded to my org and I don't see anywhere else to change the logo in the app config.

 

0 Kudos
1 Solution

Accepted Solutions
RyanLibed
Esri Contributor

Hi Sara,

Just a quick follow up. A fix has been implemented and logos should appear in the header now. 

Within Chart Viewer's app configuration, you'll need to enable the 'Shared theme' setting. 
If express setup is on, the setting will be in Theme & Layout.
If express setup is off, the setting will be in Theme & Layout > Theme. 

Finally, you'll need to upload a logo within your organization's settings. 

Sample app: 
https://webapps.maps.arcgis.com/apps/instant/charts/index.html?appid=349bb4e15d5c4159bf66c5f6a7bc894...

Please let us know if you have further questions. 

Thanks,
Ryan

View solution in original post

6 Replies
ABishop
Regular Contributor II

Hello @SaraKidd 

It seems the app is inherent of your organization settings.  Make sure that the shared logo for your org is shared publicly.  

Amanda Bishop, GISP
0 Kudos
SaraKidd
Occasional Contributor

@ABishop The logo is uploaded to my organization and it appears on the organization home page publicly. I don't see any other settings? I'm looking in my Org under the General page.

0 Kudos
ABishop
Regular Contributor II

I tried doing the same thing just now and my org logo isn't showing in the header either.  Maybe like you said, since its BETA, they haven't added this customization setting yet.  Maybe try putting this post in the idea board on GeoNet?  I'll vote for you! 

Amanda Bishop, GISP
0 Kudos
BethRomero
Esri Contributor

Thanks for the feedback, shared theme logos will show in the header of the Chart Viewer app in the next update of ArcGIS Online. 

0 Kudos
RyanLibed
Esri Contributor

Hi Sara,

Just a quick follow up. A fix has been implemented and logos should appear in the header now. 

Within Chart Viewer's app configuration, you'll need to enable the 'Shared theme' setting. 
If express setup is on, the setting will be in Theme & Layout.
If express setup is off, the setting will be in Theme & Layout > Theme. 

Finally, you'll need to upload a logo within your organization's settings. 

Sample app: 
https://webapps.maps.arcgis.com/apps/instant/charts/index.html?appid=349bb4e15d5c4159bf66c5f6a7bc894...

Please let us know if you have further questions. 

Thanks,
Ryan

SaraKidd
Occasional Contributor

Thanks so much. For the benefit of anyone else reading this, I discovered that there are actually two places in the organization settings to upload a logo. I had one already loaded for the main account but there is also a place to upload a logo in the shared theme section in the settings. The second one is what appears in the app.

0 Kudos