Issue in the creation of Preliminary Pathways

464
5
12-08-2023 02:59 AM
AbhyanshuGupta
New Contributor III

Hi,

I was working on a custom Indoor Viewer App so for that I was creating the pathways and the transition. After i had created the Preliminary Pathways I have noticed that not all the pathways are interconnecting resulting in leaving many units not connected. I have attached the images also. As u can see there are bunches of pathways which are not inter-connected even though I have mentioned doors as open. Why am i facing such an issue. Also when I created the network dataset and used it on the Indoor Viewer application I am able to create only few paths for some stops for the rest i am getting 'There was a problem generating directions for these stops' error.

Is there any way i can resolve these issues and the error.

Regards

Screenshot 2023-12-08 154745.png

Screenshot 2023-12-08 154716.png

Screenshot 2023-12-08 162822.png

  

0 Kudos
5 Replies
MappyIan
Occasional Contributor II

Hi @AbhyanshuGupta, you need to reduce the Lattice Density value to ensure that your network is more inter-connected.  See the section on the help page linked below for further information but basically the value of this parameter determines the length between each node in the network.  The smaller the value, the more dense the network and the more likely the network will extend in to all rooms in your building.  Also be aware that the smaller the value, the longer the tool will take to run.

https://pro.arcgis.com/en/pro-app/latest/tool-reference/indoors/generate-indoor-pathways.htm

Presumably this is the reason that you're not able to route to some of the points in your dataset (if the network isn't fully connected you won't be able to route to points in disconnected rooms).  Hopefully once you've regenerated your network and it extends in to all rooms you should be able to route to all your points.

Hope this helps.

AbhyanshuGupta
New Contributor III

Hi @MappyIan , thanks for reply. I did try by lowering down the lattice density and there are units which have been connected now but not all the units are connected. I also did try creating a network dataset using this on indoor viewer but i am till facing the same error. I had kept my lattice density to 0.3.

0 Kudos
MappyIan
Occasional Contributor II

You could lower the lattice density to 0.25 (which is the lowest value it will accept) to see if that resolves the issue with not all rooms being connected to the network.  If that doesn't work, I think the only other option is to manually digitise connections through the doorways to connect the unconnected rooms.  It's just a line dataset after all so once it's created you can make manual edits to the preliminary pathways dataset.

It's also worth checking the features you're using as barriers as mentioned by @AnninaHirschiWyss as it does look like your preliminary pathways are going through walls, which is not what you're going to want when using it for routing.  Good spot @AnninaHirschiWyss, I hadn't noticed that!

Hope this helps.

0 Kudos
AnninaHirschiWyss
Occasional Contributor II

Hi @AbhyanshuGupta it also looks like your lattice goes through walls.

Did you specify the correct level (for units, levels, details) when creating the prelim pathways?
Did you specify the walls as a barrier?
In your "Details": Are there any "wall-lines" on top of the doors? If yes, these will block the pathways.
Does your "Levels" feature class contain continuos polygons without holes and parts? If not, delete holes and parts.

Best,

Annina

Jinho_Kang
Occasional Contributor

Also make the preliminary pathway floor-aware (Layer Property -> Floors -> Floor Field = Level_ID) if you haven't done it yet... Looks like you have more than one floor.

0 Kudos