Export orthorectified image problems

623
6
06-18-2020 08:17 AM
ZoeStroebele
New Contributor

Hello !

I'm working with Pleiades images. I have orthorectified my pan-sharpened images they appear correctly in my project but when exporting the saved image seems changed. The radiometry is different and the image appears to be divided into blocks. I've tried different NoData settings, promoting pixels, radiometric adjustment etc.. This happens whether I used the image analysis window or the function chain to orthorectify the image. This doesn't happen when I save my orthorectified panchromatic image is exported.

Once again the orthorectified image appears correctly until I try to save/export it. 

What am I doing wrong?  Any help is super appreciated 

 orthorectified image before export (left), after export (right)

function chain for my pan-sharpened image.

0 Kudos
6 Replies
SimonWoo
Esri Contributor

Which version of ArcMap are you using? 

I know there was a bug in older version of ArcMap with pan-sharpened raster products and saving it after using a function.  Also, sometimes if you calculate statistics on your original raster product (pan-sharpened product) it solved this issue "sometimes".

So you may need to calculate statistics and more importantly be on a newer version of the software.

Let us know if either of those suggestions work.

ZoeStroebele
New Contributor

Hello ! Thank you so much for your response ! 

I'm using ArcMap 10.7.1. 
I tried calculating the statistics before exporting and the result is better. There is still some radiometry is still wonky but the blocks above the water in the upper right are resolved.

                                       pan-sharpened and orthorectified with stats calculated (left), after exporting (right)

Any other ideas ? Could it be the way NoData is being managed (or not managed) ?

0 Kudos
SimonWoo
Esri Contributor

Assuming all your black background is uniformly a value of 0, use 0 as your NoData value when you Export

0 Kudos
ZoeStroebele
New Contributor

Ok, So it isn't a NoData problem. 

0 Kudos
SimonWoo
Esri Contributor

There is also this other thread about NoData that you can try - if you want to make a mosaic dataset.

https://community.esri.com/message/935812-re-no-data-values-collars-error-delete-values-from-image?c... 

0 Kudos
ZoeStroebele
New Contributor

Thanks again for your help !

I will read this and see if it helps. Once again everything is fine before the export. And it is only a problem with the pansharpened image not the panchromatic. So maybe there is a resampling problem when the image is saved? Obviously I'm really new at this. I'm an intern but because of covid I'm working from home. Flying solo into a brave new world !

0 Kudos