Phantom items in Open Data Beta

1012
16
Jump to solution
11-18-2016 07:10 AM
KevinDunlop
Occasional Contributor III

I am having an issue with Phantom items in the Open Data Beta.  Basically, it will create two records for the same item, one gets update and the other does not.  It happens when changing ownership and index number.  I am able to reproduce this problem by following steps:

1.  Create an Feature Layer in AGOL under first user (ex myUser).  I used URL of https://myOrg.com/arcgis/rest/services/myFolder/mySerice/MapServer/13 for example

2. Assign Feature Layer to a group(s).

3. Change ownership to a different user (ex myOrg)

4. In a new browser tab, update index in Open Data data manager

5. In previous AGOL tab, change layer index in URL.  Example change 13 to 7 so that it is now  https://myOrg.com/arcgis/rest/services/myFolder/mySerice/MapServer/7

6. In previous Open Data tab, update index in Open Data data manager

You show now have two records for the same layer but with different users each.  You can test this by deleting feature layer.  One of the records will disappear and the other will remain.  In addition, the remaining layer points to a broken URL.  

I have been unable to remove these phantom item records no matter what I try.  Here is some screen shots on an example (Railroad).

Does anyone know how to remove these phantom items?   Thanks,


Kevin Dunlop

GIS Database Developer

Prince William County.

Tags (1)
1 Solution

Accepted Solutions
CourtneyClaessens
Occasional Contributor III

Hi Kevin, 

Can you please provide the open data URLs for the dataset you'd like to be removed? 

Thank you for the detailed STR - I will log a bug with our engineering team. 

Courtney

View solution in original post

16 Replies
C_EHoward
Occasional Contributor III

I have a similar problem that just started happening again this morning.I updated my map service with additional layers/tables and now there are duplicates because the names are the same.

In the past, the Open Data team has had to go in and remove phantom stuff but sometimes updating the index takes care of it. I am hoping that the indexing I restarted will address the issue. But I do notice that this happens when I try and work with an existing service more than when adding a new one. So maybe be patient and see what happens?

I notice you didnt have any errors/warnings in your data listing, a good thing but that would be my other theory. 

Good luck-- I have an interest in your site being up and running (fellow DMV'er here  )

CourtneyClaessens
Occasional Contributor III

Hi Charlene, 

Let me know if this doesn't clear up and we'll take a look. 

Courtney 

C_EHoward
Occasional Contributor III

Thanks Courtney. I am going to see if it resolves itself soon. I even created a new content item and un-shared the old one but it they both still appear. And strangely, only the tables in my service have items listed- the feature class (layer 0) does not appear....and that is what people are going to want to download. Before I updated the service, all layers were visible (one FC and 4 tables) and now with the updated service, only 5 tables are there (instead of one FC and 5 tables). And my duplicate service behaves the same way so I am thinking I may have to go back and look at the MXD as well. 

0 Kudos
C_EHoward
Occasional Contributor III

Courtney, I deleted the service but the content is still in Open Data despite deleting the content item as well. I would like to republish using this service name but do not want to until this phantom is banished to the netherworld. My rogue datasets can be found at Esri | ArcGIS Open Data  with layers 0 through 5. thanks for the help.

0 Kudos
C_EHoward
Occasional Contributor III

those are the right ones-- i see duplicate content for the same layers under the 'TAZ' service which does not exist anymore. the link to the metadata item is https://www.arcgis.com/home/item.html?id=48c3d9d7524c4f4faeb4ca446cfb2684  but that does not exist anymore . cleared browser again just to make sure

0 Kudos
CourtneyClaessens
Occasional Contributor III

Alrighty you should be good to go now! 

0 Kudos
C_EHoward
Occasional Contributor III

thanks- looks good!

0 Kudos
CourtneyClaessens
Occasional Contributor III

Hi Kevin, 

Can you please provide the open data URLs for the dataset you'd like to be removed? 

Thank you for the detailed STR - I will log a bug with our engineering team. 

Courtney

View solution in original post