Hub Dataset Download API Error

167
2
Jump to solution
09-13-2021 08:46 AM
John_Spence
Occasional Contributor II

Interesting situation folks....

One of our datasets Bellevue Permits is throwing errors when folks try to access and download via the point/click download button interface.  Here is what they are seeing:

John_Spence_0-1631546461023.png

From the developers console, we are seeing this:

John_Spence_1-1631546513674.png

There is a potential workaround if you are seeing that though.

On the URL, dump the portions everything after the datasets name:

and you will get an error free interface.

John_Spence_3-1631546735427.png

 

This work around has been successful for small record sets, but in my 93K record set for this example....it errors out.  Here is an example though of what is going on during the wait for download.

John_Spence_4-1631547866466.png

This particular hosted dataset was created from a CSV file that is geocoded during ingestion.  I dumped the original service and recreated it just to make sure it was not something I did.  I have also forced the hub site to look for updates too, but as we are all familiar with, sometimes that is not an instant resolution.  This service is a view though as we only wanted to display records from the last 5 years and, for export purposes, the service was modified to allow for more than 1000 records to be exported at a time (refer to TA 000012383).

So has anyone else been running into this particular issue?

0 Kudos
1 Solution

Accepted Solutions
ThomasHervey1
Esri Contributor

Hi,

How are you accessing that item? Are you trying to navigate to the URL directly, or are you using the gallery card found on https://data.bellevuewa.gov/? I think you mean the gallery card pictured below When you say "via the point/click download button interface".

Screen Shot 2021-09-13 at 5.31.11 PM.png

If this is the case, this is a known bug that will be fixed during tomorrow's weekly release.

View solution in original post

0 Kudos
2 Replies
ThomasHervey1
Esri Contributor

Hi,

How are you accessing that item? Are you trying to navigate to the URL directly, or are you using the gallery card found on https://data.bellevuewa.gov/? I think you mean the gallery card pictured below When you say "via the point/click download button interface".

Screen Shot 2021-09-13 at 5.31.11 PM.png

If this is the case, this is a known bug that will be fixed during tomorrow's weekly release.

View solution in original post

0 Kudos
ToddMetzler
Occasional Contributor II

Please see Same reporting