Hub Application Item Open in New Tab

82
4
06-29-2022 11:51 AM
KansasDASC
New Contributor II

We have a number of applications that are discoverable in our Hub site. There is one item that has a symbol next to it in the search results that when clicked, opens the application in a new tab, outside of Hub.

Then there's other applications that don't have this symbol and when clicked, opens the application as a Hub item showing the application, but surrounded by the Hub application.

How do I add or remove this symbol/ability, so that all applications open external to the Hub, or remove it so that all applications can open inside of the Hub?

Hub Open External.png

versus...

Hub Open Internal.png

0 Kudos
4 Replies
KlaraSchmitt
Esri Contributor

@KansasDASC ,

In your site editor, go to Settings > Interactions and enable the Embedded Apps toggle. This will keep applications opening under your site header and the links in search results should not display the "opens external link / new tab" symbol.

0 Kudos
KansasDASC
New Contributor II

Hi @KlaraSchmitt we already had the Embedded Apps toggled to on and as a test, I toggled it off, then back on, saved then draft, then published, and there was no change with the issue.

0 Kudos
KlaraSchmitt
Esri Contributor

Hello @KansasDASC ,

Hmm. I'm not sure then. It seems like it could be a bug; unfortunately, I am not super knowledgable when it comes to issues in the search catalog. Have you tried reaching out to Support to see if they can assist?

0 Kudos
KansasDASC
New Contributor II

Not yet, I was hoping this was something that I overlooked in the settings at the AGOL item level or configuration within Hub.

0 Kudos