Has anybody used the Clone option to clone an Open Data Site?

1842
18
Jump to solution
12-11-2017 02:25 PM
NinaRihn
Occasional Contributor III

Has anybody used the Clone option in Open Data?  It suddenly appeared as an option when you click Save in the Site Editor, but I can't find any documentation for it, and I am sorry to say I am terrified to use it, not knowing what it will actually do! 

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
CarmelConnolly
Regular Contributor

Hi Nina, 

Cloning the site creates an exact replica of the site you are cloning.

It goes through these steps and creates a new item with '- Copied' appended to the name:

I assume it's a new tool that was released with the ArcGIS Online update last week


Carmel

View solution in original post

18 Replies
CarmelConnolly
Regular Contributor

Hi Nina, 

Cloning the site creates an exact replica of the site you are cloning.

It goes through these steps and creates a new item with '- Copied' appended to the name:

I assume it's a new tool that was released with the ArcGIS Online update last week


Carmel

View solution in original post

CarmelConnolly
Regular Contributor

Open Data and ArcGIS Hub was just updated on the 12th December:

http://hub.arcgis.com/pages/changelog  

NinaRihn
Occasional Contributor III

Thank you Carmel!!

Alex-Santos
Occasional Contributor

Hi Carmel, I used the cloning site and as expected it cloned everything including the pages. I created the clone so that I could use the Site Editor and tweak it a bit to meet another open data site topic. I would like to clean up the pages that aren't relevant. But! I noticed that deleting a page in the clone also deletes the page in the original site. Is this intended behavior. I understand the benefit in editing one so that it then appears in the other. However can we remove that "link?" I don't want other team members deleting a page thinking it is only in the cloned site. Thankfully, I have a copy of everything to rebuild it. Did I miss a step somewhere?

0 Kudos
CarmelConnolly
Regular Contributor

Hi Alexandre, 

I'm not sure if that's a bug or as designed as this functionality is so new. 

I'm tagging ArcGIS Hub‌ & Courtney Claessens‌ to highlight your question!

It also might be worth logging this directly with your local Tech Support team: https://support.esri.com/en/contact-tech-support

Carmel

0 Kudos
Alex-Santos
Occasional Contributor

Hi again, okay I will log a support ticket with this. Our intention is to use this clone feature for other DC agencies that want their own, as a starting point. Also to ensure they keep certain sections to maintain a cohesive look across sites. Attached image of warning.

0 Kudos
CarmelConnolly
Regular Contributor

Hi Alexandre, 

I've just run a test (I created a new site, added 2 pages, cloned this site), deleting a page in the cloned site did not impact the original site. 

Were you linking pages together?

If you rename a page, does that impact the page on the original site?

Carmel

0 Kudos
Alex-Santos
Occasional Contributor

I'll try this again and report back. Where is the option to "link" pages together?

0 Kudos
CarmelConnolly
Regular Contributor

Hi Alexandre, 

You'll find it in the Pages tab of the Site Configuration:

Using this would mean multiple sites are looking at the same source page, rather than a cloned page. 

Carmel