Trouble getting attribute filters to work in 10.7.1 GeoEvent Service

130
0
08-16-2021 11:20 AM
AbigailStephens
New Contributor III

We have a workflow set up to read in new records to a feature layer on our Portal and send an email notification to a group of users monitoring that dataset. We are running ArcGIS Enterprise 10.7.1 on all components, Server, Portal, and GeoEvent Server.

Last week, I attempted to update this process to send emails to different groups of emails based on an attribute in the dataset. However, I kept running into a problem that no matter where I moved the filter in the GeoEvent service processing, it proved to be a stopping point for the processing.

Here is the desired workflow:

GeoNet question on GeoEvent filters.png

AbigailStephens_0-1629136023190.png

Based on the documentation, https://enterprise.arcgis.com/en/geoevent/latest/analyze/attribute-filters.htm, what we have set up should work, but since the documentation doesn't go back to 10.7, I'm wondering if there might be something I'm missing.

I tried many combinations of things, but always ended up with the filter as a block:

  • Field as a string field, tried the filter with quotes and no quotes around the text, as well as trying the field value and alias values.
  • Field as integer field, using the integer field values
  • I also tried using "=" and "MATCHES", with the resulting value as a regular expression.

We have a filter in another GeoEvent service that uses a regular expression and seems to work as expected, and I'm stuck as to why we might be having this problem with this particular feature service. Has anyone else experienced similar problems or know what might be wrong? Thanks in advance!

We have currently found a work-around for this problem using Query Definitions on 3 separate inputs, but would like to keep things cleaner with just one input and filters if possible.

Tags (2)
0 Kudos
0 Replies